applications – Incompatible apps – Android Enthusiasts Stack Exchange

Okay so, I used to use VLLO to make Gacha videos. And I also used to play among us. But, when I wanted to reinstall those apps it said my device isn’t compatible with the version of the app. Why did that happen? I don’t want this to happen. Like, one day you can install this app app and the next your device isn’t compatible with this version. Is there a way to fix this? Because, whenever I go to see if I need a software update it says that the version I have is already the latest version. Please help.

(Also, I use a galaxy tab 2 2016 version I think.)