apt – Error when trying to install external repositories and packages on Lubuntu

I am new to Linux and Ubuntu.

I have been recently working on an old laptop with Lubuntu.

I have had an error recently after attempting to download Oracle JDK11.

Every time I run the Sudo apt install <Package> or sudo apt install home/path/file.deb
I get this error: E: The Package oracle-java11-installer-local needs to be reinstalled, but I can't find an archive for it. and then it would abort the process.
I have been trying to find a fix and couldn’t. What could be causing this / the solution for this?