apt – Ibus dependency on Zoom install

I installed zoom successfully despite many error messages, only for audio to never work. So i delete it and try to reinstall, but there is an ibus dependency. Now when i try download ibus i get the following error:

sudo apt-get install ibus-gtk3
(sudo) password for ----:       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 zoom : Depends: ibus
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I started on mint this week and I am a bit lost, havent downloaded much but almost everything has run into dependency issues