apt – Problems installing python3-tk


when running
sudo apt install python3-tk
I get the following:

Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gitkraken : Depends: gconf2
             Depends: gconf-service
 python3-tk : Depends: blt (>= 2.4z-9) but it is not going to be installed
              Depends: libtcl8.6 (>= 8.6.0) but it is not going to be installed
              Depends: libtk8.6 (>= 8.6.0) but it is not going to be installed
              Depends: tk8.6-blt2.5 (>= 2.5.3) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I then run
apt --fix-broken install
which gives me the following message:

E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

When running sudo apt install python3-tk again I get the same result.

Just to see what happens and to see if I get the same result i tried pip3 install blt which succefully installs blt but doesn’t change anything about the first message I get.

I’m quite new to Ubuntu and I don’t know what to do. I would appreciate It very much if someone could help me out.

lsb_release -a:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.1 LTS
Release:    20.04
Codename:   focal

This is all happening in a anaconda environment with python v3.6.
I am using VirtualBox to run Ubuntu.