apt – Problems installing Qt on Ubuntu 16.04

I follow this link to install Qt on my PC.

When I type sudo apt-get install build-essential g ++ libqt4-core libqt4-dev libqt4-gui qt4-doc qt4-designerI get this error:

Read package lists ... Done
Create dependency tree
Status information is read ... Done
build-essential is already the latest version (12.1ubuntu2).
g ++ is already the latest version (4: 5.3.1-1ubuntu1).
Some packages could not be installed. This can mean that you have
Requested an impossible situation or if you use the unstable
Distribution that some required packages have not yet been created
or moved from Incoming.
The following information may help correct the situation:

The following packages have unfulfilled dependencies:
libqt4-core: Dependent: libqt4-dbus (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
Dependent: libqt4-network (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
Dependent: libqt4-script (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
Dependent: libqt4-test (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 must be installed
Dependent: libqt4-xml (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
Dependent: libqtcore4 (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
libqt4-gui: Dependent: libqt4-designer (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
Dependent: libqt4-opengl (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
Dependent: libqt4-svg (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 must be installed
Dependent: libqtgui4 (= 4: 4.8.6 + git64-g5dc8b2b + dfsg-3 + deb8u1), but 4: 4.8.7 + dfsg-5ubuntu2 needs to be installed
E: Problems can not be solved. You have stored defective packages.

I followed this link for help after I entered this command sudo apt install libqt4-designer libqt4-opengl libqt4-svg libqtgui4 libqtwebkit4I should create a script file, but I can not really understand how to do that.

This command was executed successfully sudo apt-get install libqglviewer-dev libqglviewer2 but this sudo apt-get install libboost1.48-all-dev not, I got this error:

Read package lists ... Done
Create dependency tree
Status information is read ... Done
E: Package libboost1.48-all-dev could not be found
E: Could not get a package from Glob & libboost1.48-all-dev & # 39; Find
E: Unable to find package from libboost1.48-all-dev.

How can all this be remedied?