array – ALGORITMO VISUALG – MOSTRAR O NÚMERO DE REPETIÇÕES DE UMA LETRA NUMA PALAVRA

Ola !!!

Estou desenvolvendo um Algoritmo em que a pessoa digita uma palavra qualquer e o programa mostre o número de repetições por letra na palavra.

Por exemplo: ALANA .

Tem como resposta:

A = 3 /
L = 1 /
N = 1

Entretanto, nao consigo mostrar somente isso, so consigo fazer com que mostre todas as letras. No caso

A = 3 /
L = 1 /
A = 3 /
N = 1 /
A = 3

Não queria que se repetissem letras que já foi feita a análise. Mas infelizmente parei aqui e não consigo deixar como gostaria.

Agradeço demais toda a ajuda.

Aqui vai o programa

Var

palavra, letra, comparacao : caractere

i , j , cont : inteiro

Inicio

escreval

escreva(“Digite uma palavra: “)

leia(palavra)

escreval

para i de 1 ate compr(palavra) faca

letra := copia( palavra, i , 1 )

para j de 1 ate compr(palavra) faca

     comparacao := copia( palavra, j , 1 )
 
      **Se letra = comparacao entao**
      
         cont := cont + 1
         
      **fimse
 
 fimpara**

 
 

escreval(letra , ” = “, cont)

escreval

cont := 0

fimpara

Fimalgoritmo