bitcoin qt setup – QT compiling for Debian systems

Bitcoin version : 0.21
System: Ubuntu 18.04

All dependencies installed.

I am using Depends system to compile QT wallet. I compiled all three (Mac, Windows, and Ubuntu) successfully. All run just fine.

Only with Ubuntu, the QT file doesn’t open with double click like other programs. How do I compile it so it works just like other programs, and I don’t have to open terminal every time I want to run the QT wallet.