boot – When the hard disk of Ubuntu is mounted on the motherboard, the hard disk of Windows 10 does not appear


This year I am starting my specialty in Informatics so I thought Ubuntu is a must, but I didn’t want to abandon Windows either.
I decided to mount a second NVMe gen3 and dual boot Ubuntu 20.04 (on the computer there is also an HDD just for storage). To do so, I first removed the hard disk that has installed Windows so I would be sure that no partitions of the one OS would appear to the other one. I managed to install Ubuntu and it was working perfectly. I then mounted back the second NVMe with the Windows to verify that the dual boot was working correctly. Things didn’t go as expected.

When both hard disks are connected, the hard disk of Windows doesn’t appear in the BIOS and I obviously cannot access Windows. When I take out the hard disk of Ubuntu, Windows boots normally. Before installing Ubuntu I verified that my Windows was in UEFI mode so I also installed Ubuntu in UEFI mode. I tried to change the slots just in case but it changed nothing. Then I tried to use in Ubuntu the Boot-Repair and the outcome was this link that I have to admit, I don’t really know for what I should be looking. I also tried the command sudo update-grub but once again nothing.

I would really appreciate it if somebody could help me…