coding style – Standarized prefixes for naming REST POJO (Correct or not correct)?

We are building a software application for a client with a particular naming convention for REST services.

For example if you use a POJO for your request or response in a REST service something like that:

public class Document {
    private String codeDocument;
    private String codeParentDocument;
    private Double amountPayed;
    private String nameOwner;
    private String descriptionDocument;
}

Your REST contract should be so:

{
  "codDocument": "123",
  "codParentDocument": "123",
  "amtPayed": 25.5,
  "desDocument": "owner"
}

This is an example because there a list of many prefixes. This prefixes are used by the organization as convention for its database fields.

I think They want to have some type of homologation between its REST contract and its tables. Another reason could be the fact REST contract in some occasions has many fields and it could cause confusion. Therefore prefix would help to people to distinguish the meaning of a particular field among of many other fields. They could know if a field is a description, amount, code, etc…

But…I recognize that in some occasions this prefix are redundant. For example codeDocument could be simply code. Another example is with DNI (Identity National Document). It should be defined as dni but people from client prefer to use numberDni. DNI is a number, is redundant put the word “number” before…

Another minor problem is many applications from the client use this standard. We would be the only one with get out from the their standards.

I consider that use prefix is not correct but I would like have other opinions and if possible more arguments to convince to my client of my project. Thanks a lot (Y)