compiling – need to compile. from source┬Žno configure, no readme available

I downloaded the angryIP scanner in 2.x and 2.21. The old version, because I need to run it on a Tegra (ARM) processor. The universal plattform .deb fails to install, so it seems not to be that universal… However, the archive comes with all the .h and .cpp files, but no makefile.am, makefile.im, configure, readme or whatever. I tried a couple of hours now with the auto(re)conf tools, but I fail. Any idea how I can get this compiled and installed? For dummies please…