Composer downgrading module version – Drupal Answers

I wish to move the bootstrap theme from the repository
located in the folder theme/custom to be a dependency in composer.json

I’ve checked that the current version drupal/bootstrap is 3.16

I perform rm -rf web/theme/custom/bootstrap
composer require drupal/bootstrap:8.x-3.16
^^-> wrong syntax and have decided to just composer require drupal/bootstrap

Now I need to downgrade the version of drupal/bootstrap in composer.json
and perform composer update --lock  

But I got an error:

Nothing to modify in lock file
Unable to find a compatible set of packages based on your non-dev requirements alone.
Your requirements can be resolved successfully when require-dev packages are present.
You may need to move packages from require-dev or some of their dependencies to require.

  Problem 1
    - Root composer.json requires drupal/bootstrap 3.16, found drupal/bootstrap[3.23.0] but it does not match the constraint.

Any hints would appreciate.