Custom Post Types – CPT rewrite the pages of 404

Feature products_post_type () {

$ labels = Array (
& # 39; name & # 39; => _x (& # 39; Products & # 39 ;, & # 39; Post Type General Name & 39 ;, text_domain & # 39;),
& # 39; # 39 & singular_name; => _x (& # 39; Product & # 39; Post Type Singular Name & # 39 ;, & # 39; Text_Domain & # 39;),
& # 39; # 39 & menu_name; => __ (& # 39; products & # 39 ;, & text; domain_ & # 39;),
& # 39; # 39 & name_admin_bar; => __ (& # 39; products & # 39 ;, & text; domain_ & # 39;),
& # 39; # 39 & archives; => __ (& # 39; Product Archive & # 39 ;, & # 39; text_domain & # 39;),
& # 39; attributes & # 39; => __ (& # 39; product attributes & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & parent_item_colon; => __ (& # 39; Parent: & # 39 ;, & text 39; text_domain & # 39;),
& # 39; # 39 & all_items; => __ (all products & 39 ;, text_domain & # 39;),
& # 39; # 39 & add_new_item; => __ (& # 39; add new product & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & add_new; => __ (& # 39; add new product & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & new_item; => __ (& # 39; new product & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & edit_item; => __ (& # 39; edit product & # 39 ;, & text 39; text_domain & # 39;),
& # 39; # 39 & update_item; => __ (& # 39; update product & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & view_item; => __ (& # 39; view product & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & view_items; => __ (& # 39; show products & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & search_items; => __ (& # 39; search products & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & not_found; => __ (& # 39; not found & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & not_found_in_trash; => __ (& # 39; Not found in Trash & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & featured_image; => __ (& # 39; product image & # 39 ;, & text; domain_ & # 39;),
& # 39; # 39 & set_featured_image; => __ (& # 39; product image & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & remove_featured_image; => __ (& # 39; remove product image & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & use_featured_image; => __ (& # 39; use as product image & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & insert_into_item; => __ (& # 39; insert into element & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & uploaded_to_this_item; => __ (& # 39; uploaded to this itproductm & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & items_list; => __ (& # 39; product list & # 39 ;, & # 39; text_domain & # 39;),
& # 39; # 39 & items_list_navigation; => __ (& # 39; product list navigation & # 39 ;, & text 39; text_domain & # 39;),
& # 39; # 39 & filter_items_list; => __ (& # 39; filter product list & # 39 ;, & text 39; text_domain & # 39;),
);
$ args = array (
& # 39; label & # 39; => __ (& # 39; product & # 39 ;, text_domain & # 39;),
& # 39; description & # 39; => __ (& # 39; products & # 39 ;, & text; domain_ & # 39;),
& # 39; labels & # 39; => $ labels,
& # 39; supports & # 39; => Array (& # 39 ;, Title & # 39 ;, & # 39; Thumbnail & # 39;),
& # 39; hierarchically & # 39; => true,
& # 39; public & # 39; => true,
& # 39; # 39 & show_ui; => true,
& # 39; # 39 & show_in_menu; => true,
& # 39; # 39 & menu_position; => 5,
& # 39; # 39 & menu_icon; => & # 39; dashicons-products & # 39 ;,
& # 39; # 39 & show_in_admin_bar; => true,
& # 39; # 39 & show_in_nav_menus; => true,
& # 39; # 39 & can_export; => true,
& # 39; # 39 & has_archive; => true,
& # 39; # 39 & exclude_from_search; => false,
& # 39; # 39 & publicly_queryable; => true,
& # 39; # 39 & Capability_type; => & # 39; page & # 39 ;,
& # 39; # 39 & show_in_rest; => false,
// & # 39; rewrite & # 39; => array (& # 39; slug & # 39; => & # 39;% category% & # 39 ;, & # 39; with_front & # 39;;> false)

);
register_post_type (& # 39; product & # 39 ;, $ args);

}
add_action ('init', 'app' 'products_post_type');

When I activate it rewrite Everyone does it page (not product) 404 even after deleting permalinks.

The same happens when declaring a custom taxonomy.

Is there a reason why this would happen?

I use the theme Sage 9.0.5 with Trellis and Bedrock & WP V5.0.3