flutter – No se puede instalar

Mi app fue desarrollada en Flutter.

Pero cuando intentan instalar desde Play Store arroja error.
Error de Play Store

Este error se mantiene en equipos con Android 6.0.1 y 7.0.
Ademas en el equipo con Android 6.0.1, intente instalar desde el apk pero me arroja “Error de análisis se produjo un error durante el análisis del paquete”

¿Alguien sabe como solucionarlo?

Tiene esta configuración en build.gradle
minSdkVersion 21
targetSdkVersion 29