fuse – Can’t run an AppImage on Ubuntu 20.04

I’m not able to run AppImages on my Ubuntu 20.04. All the permissions are ok (see pic 1) and I have tried the terminal too (see pic 2). The messages in the terminal are dlopen(): error loading libfuse.so.2 and AppImages require FUSE to run. but fuse is already installed (see pic 3), it says fuse is already the newest version (2.9.9-3). I’ve tried to reinstall fuse with the --reinstall apt option, same results.

Any thoughts?

Thank you in advance 🙂

Permissions are ok

Tried the terminal

Fuse is already installed