installation – Can not install Mangento

I’m trying to install magento 2.3.4:

bin/magento setup:install 
      --no-interaction 
      --backend-frontname admin 
      --db-host mysql 
      --db-name mage2 
      --db-user root 
      --db-password secret 
      --admin-firstname John 
      --admin-lastname Doe 
      --admin-email admin@localhost.com 
      --admin-user admin 
      --admin-password adminadmin123 
      --base-url "http://127.0.0.1:8000" 
      --use-secure 0 
      --use-secure-admin 0 
      --timezone Asia/Tokyo 
      --use-rewrites 1 
      --session-save redis 
      --session-save-redis-host redis 
      --session-save-redis-db 4 
      --cache-backend=redis 
      --cache-backend-redis-server redis 
      --cache-backend-redis-db 5 
      --page-cache=redis 
      --page-cache-redis-server redis 
      --page-cache-redis-db 6 
      --use-sample-data

My composer.json file is:

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "license": (
        "OSL-3.0",
        "AFL-3.0"
    ),
    "config": {
        "preferred-install": "dist",
        "sort-packages": true
    },
    "require": {
        "php": "7.3.*",
        "ext-curl": "*",
        "ext-json": "*",
        "magento/product-community-edition": "2.3.4"
    },
    "require-dev": {
        "allure-framework/allure-phpunit": "~1.2.0",
        "friendsofphp/php-cs-fixer": "~2.14.0",
        "lusitanian/oauth": "~0.8.10",
        "magento/magento-coding-standard": "~3.0.0",
        "magento/magento2-functional-testing-framework": "2.4.5",
        "pdepend/pdepend": "2.5.2",
        "phpcompatibility/php-compatibility": "^9.3",
        "phpmd/phpmd": "@stable",
        "phpunit/phpunit": "~6.5.0",
        "sebastian/phpcpd": "~3.0.0",
        "squizlabs/php_codesniffer": "~3.4.0",
        "tddwizard/magento2-fixtures": "^0.9.0"
    },
    "conflict": {
        "gene/bluefoot": "*"
    },
    "autoload": {
        "psr-4": {
            "Magento\Framework\": "lib/internal/Magento/Framework/",
            "Magento\Setup\": "setup/src/Magento/Setup/",
            "Magento\": "app/code/Magento/",
            "Zend\Mvc\Controller\": "setup/src/Zend/Mvc/Controller/"
        },
        "psr-0": {
            "": (
                "app/code/",
                "generated/code/"
            )
        },
        "files": (
            "app/etc/NonComposerComponentRegistration.php"
        ),
        "exclude-from-classmap": (
            "**/dev/**",
            "**/update/**",
            "**/Test/**"
        )
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\Sniffs\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\Tools\": "dev/tools/Magento/Tools/",
            "Magento\Tools\Sanity\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\TestFramework\Inspection\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\TestFramework\Utility\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "version": "2.3.2",
    "minimum-stability": "stable",
    "repositories": (
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ),
    "extra": {
        "magento-force": "override"
    }
}

I had run the setup:di:compile previously. When I run the installation command above, I get the following error:

Starting Magento installation:
File permissions check...
(Progress: 1 / 1313)
Required extensions check...
(Progress: 2 / 1313)
Enabling Maintenance Mode...

In Mysql.php line 110:

  SQLSTATE(42S02): Base table or view not found: 1146 Table 'mage2.core_config_data' doesn't exist, query was: SELECT `main_table`.* FROM `core_config_data` AS `main
  _table`


In Mysql.php line 91:

  SQLSTATE(42S02): Base table or view not found: 1146 Table 'mage2.core_config_data' doesn't exist

I commented out all plugins in the config.php file and removed the app/code directory but it didn’t help. The database exists and empty.

What I’m doing wrong?