Kubuntu 20.04 – front panel audio jacks “unplugged” and Analog Stereo Duplex profile “unavailable”

I have a fresh Kubuntu 20.04 installation on a desktop PC. The system has a built-in HDA Intel audio card with Realtek ALC889 chip that is on the motherboard. It also has an Nvidia audio controller that is not used.

I have speakers connected on the line-out jack on the back panel and headphones+microphone connected on the front panel.

All this was working fine on my previous Kubuntu 14.04 installation. I also had Auto-Mute disabled in alsamixer, such that audio is available on both speakers and headphones at the same time.

On the new installation, the front panel is not working.

The Volume icon in the system tray and System Settings / Sound show two devices: Line Out and Digital Input (S/PDIF).

In pavucontrol, I can see Line Out (plugged in) in Output Devices. I change to Headphones (unplugged), in which case the headphones work but not the speakers, although Auto-Mute is disabled in alsamixer. In Input Devices, only Digital Input (S/PDIF) is available.

In pavucontrol / Configuration, I can see the Nvidia audio controller that is disabled and the Built-in Audio that is enabled and has the Analog Stereo Output + Digital Stereo (IEC958) Input profile selected. From the list, I change to Analog Stereo Duplex (unavailable). Now I can see Front Microphone (unplugged) in Input Devices and the microphone works.

However, System Settings / Sound / Advanced has its own list of Built-in Audio profiles, which does not include Analog Stereo Duplex. Apparently, this list does not include anything that is unavailable. As a result, I have to change the profile at every restart.

I understand that the front panel audio jacks show incorrectly as “unplugged”, which is what makes the Analog Stereo Duplex “unavailable”.

At a minimum, I would need to have Analog Stereo Duplex profile permanently selected even if “unavailable”. Also I would need Line Out and Headphones working at the same time, even if the latter is “unplugged”.

Ideally, the front panel jacks should be “plugged in”, the Analog Stereo Duplex profile should not be “unavailable” in pavucontrol and it should be listed in System Settings / Sound / Advanced such that it is permanently selected.

I have tried a few ideas I found online but nothing works. The only useful information I found is pulseaudio -k so that I do not need to restart the computer at every change I attempt.

I have installed the same Kubuntu 20.04 on another desktop PC with the same panel and speaker/headphone/microphone configuration and no issues.

Any ideas?