mac appstore – M1 compatibility of the following apps:

I am curious to know if anybody has been able to get the following applications to work on M1 Macs yet? Any actual experience with the applications and M1 would be nice.

Deckset

LibreOffice (I am aware of Collabora’s fork being allegedly compatible, I am asking about the main LibreOffice fork)

Lyx

Marked

Microsoft Teams

Screenflow

Any reasons why some of these should not be expected to be every ported to M1? (I hear such rumours for Lyx).