magento2 – Magento 2.4 Blank page for store or admin pages after installation


this is my first time setting up a Magento2 server, I’ve followed the guide from the official website.

I am using PHP 7.4, mysql, apache, all on the same host.

I pulled the repo to /var/www/html where it puts itself into /var/www/html/magento2

I then run “composer install” within /var/www/html/magento2, which does its thing without error.

Then I run the magento install using bin/magento, which does its thing without error once again.

Since I just want to test for now, I’ve set the base url as 127.0.0.1/magento2.

According to every guide I’ve found, after that, I should only have to go to 127.0.0.1/magento2 and see the store, but I get a blank page instead. The default apache page on 127.0.0.1 works just fine, tested both locally and remotely with another computer on the lan, and on both 127.0.0.1/magento2 returns a blank page.

The PHP memory is set to 2G, I’ve done every little recommendation from the official guide. Since this was for a test run, I am running the webserver as root, so it shouldn’t be getting file permission issues (it passes the file permission check on the install).

Any help would be greatly appreciated, thank you for your time.

Edit: So the webserver installation seems to be fine, if I modify the index.php to do an echo test, that works fine, that means the issues seems to be within the running of the application within the index.php and further down the line but I am not getting any errors out of it. That means it doesn’t trigger the try/catch (which would output something) and then crashes later on.