magento2 – Reference to undeclared plugin

I’ve upgraded my site from v2.3.1 to v2.3.6 and I now get the error:

Reference to undeclared plugin with name ‘priceIndexUpdater’

in my system.log.

I’ve found that in vendormagentomodule-inventory-catalogetcdi.xml there is the line

    <plugin name="priceIndexUpdater" disabled="true"/>

Why is the plugin disabled when it is needed. Any ideas what will happen if I delete the line?