magento2 – unable to install module via composer

I’m trying to install a couple of modules through composer on Magento 2.4 using the default composer.json, however it fails. I’m using composer version 1.10.21. According to the official documentation I should use the following line:

composer require myparcelnl/magento

Output:

Using version ^4.1 for myparcelnl/magento
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package magento/product-community-edition could not be found                                                                              in any version, there may be a typo in the package name.
  Problem 2
    - myparcelnl/magento 4.1.4 requires magento/product-community-edition ~2.3.0                                                                              || ~2.4.0 -> no matching package found.
    - myparcelnl/magento 4.1.3 requires magento/product-community-edition ~2.3.0                                                                              || ~2.4.0 -> no matching package found.
    - myparcelnl/magento 4.1.2 requires magento/product-community-edition ~2.3.0                                                                              || ~2.4.0 -> no matching package found.
    - myparcelnl/magento 4.1.1 requires magento/product-community-edition ~2.3.0                                                                              -> no matching package found.
    - myparcelnl/magento 4.1.0 requires magento/product-community-edition ~2.3.0                                                                              -> no matching package found.
    - Installation request for myparcelnl/magento ^4.1 -> satisfiable by myparce                                                                             lnl/magento(4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4).

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your min                                                                             imum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more det                                                                             ails.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further commo                                                                             n problems.

Installation failed, reverting ./composer.json to its original content.

I’ve made sure the credentials are correct and placed in auth.json. Currently I’m really stuck, any help would be appreciated.

Also tried to do a manual install, plugin appears in the backend but when open it, it shows an error:

2 exception(s):
Exception #0 (MagentoFrameworkExceptionLocalizedException): Invalid block type: MyParcelNLMagentoBlockSystemConfigFormSupportTab
Exception #1 (ReflectionException): Class MyParcelNLMagentoBlockSystemConfigFormSupportTab does not exist