motherboard – Changed from an i5 4440 to an i7 4790. The latter makes the CPU led turn red, while the first works fine. What can i do?


  • Motherboard – ASUS Z87-Pro;
  • CPU – i5 4440 (with Cooler Master Hyper 212 Evo V2);
  • GPU – Gigabyte GeForce GTX 1070;
  • PCU – Corsair VS550;
  • RAM – 2 kits of G.SKILL Ripjaws DDR3 1600 CL9 2x8GB (32GB in total);

I had my PC set with the specs I just specified and all was running smoothly. Today I tried swapping my CPU for an i7 4790, which I had in another PC, but, when I tried booting it up, it turned on the CPU led (with Q-Code 00) and the fans, but did not give any other response (the monitor had no signal).

I tried swapping back to my old CPU and all was running smoothly again.
Tried updating the BIOS to the newer version through EZ Flash 2, and did not work with the new CPU, though it worked with the old one.
I then tried to update the BIOS through USB BIOS flashback and it still did not work with the new one (it worked with the old one).

At this moment I am really not sure what to do. I thought it might be due to a RAM issue, but since it works on the old one I’m really doubting that.

Appreciate any replies.