mount – External Blu-ray / DVD drive does not work on my Ubuntu computer (but under Windows)

I bought a new external Blu-ray / DVD drive (LG WH16NS40) connected via USB and can not get it to work on my Ubuntu 18.04 computer. It works perfectly on my old Windows 7 laptop.

This is what Disk Utility looks like when I select the drive: https://i.imgur.com/X5tcb4G.png.

These are the things I tried after I googled:

  • Some people recommended doing lshw -C disk to see if the drive is listed, but this only depends on & # 39; SCSI & # 39; when the drive is plugged in and nothing is output. When I do lshw -C disk Immediately after plugging in the drive, however, it works:
  *-cdrom                   
       description: DVD-RAM writer
       product: BD-RE  WH16NS40
       vendor: HL-DT-ST
       physical id: 0.0.0
       bus info: scsi@3:0.0.0
       logical name: /dev/sr0
       version: 1.03
       capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
       configuration: status=ready
     *-medium
          physical id: 0
          logical name: /dev/sr0

But if I do it again a second later, it hangs.

  • If I pull the plug out of the socket The drive will display this error message (& # 39; Color of Paradise & # 39; is the name of the movie): https://i.imgur.com/ZbrXadZ.png.

  • eject does not work and also hangs when the drive is plugged in

  • Someone said something about the region that was not fixed and had to be done sudo regionsetbut that depends …

  • Sometimes the disc appears, but MakeMKV hangs when scanning "CD-ROM devices". When the drive is scanned, it will always hang when loading the CD. (The same CD worked on the Windows computer.)

  • Sometimes the drive does not even appear in the Disk Utility and I need to restart it.

Any help would be appreciated.