Página não está funcionando, após utilizar Docker

criei uma aplicação Web com Django e quando executo o comando “python manage.py runserser” a página executa normalmente. Mas depois de executar o container do Docker a página consta como não estar funcionando:

docker-compose up -d

Creating network "devbook_default" with the default driver
Creating mongodb_container ... done
Creating devbook_web_1     ... done

Dockerfile:

    FROM python:3.9

    ENV PYTHONDONTWRIETBYTECODE 1
    ENV PYTHONNUMBUFFERED 1
    
    WORKDIR /projeto
    
    COPY requirements.txt .
    RUN pip install -r requirements.txt
    
    COPY . .

docker-compose.yml

version: "3.8"

services:
  web:
    build: .
    command: python manage.py runserver
    volumes:
      - .:/code
    ports:
      - 8000:8000
    depends_on:
      - db
  db:
    image: mongo
    container_name: mongodb_container
    ports:
    - "27017:27017"
    environment:
      - MONGO_INITDB_ROOT_NAME=Devbook
    volumes:
      - /data/db:/data/db

Usando o docker-compose ps

Name                    Command             State                      Ports
------------------------------------------------------------------------------------------------------
devbook_web_1       python manage.py runserver    Up      0.0.0.0:8000->8000/tcp,:::8000->8000/tcp
mongodb_container   docker-entrypoint.sh mongod   Up      0.0.0.0:27017->27017/tcp,:::27017->27017/tcp

Quando acesso a página localhost:8000 consta assim:
inserir a descrição da imagem aqui