php – Não consigo instalar componentes no COMPOSER

Estou tentando instalar alguns componentes no meu projeto em php através do composer mas não estou conseguindo, aparecem os seguintes erros:

  • Root composer.json requires league/oauth2-facebook 2.0.1 -> satisfiable by league/oauth2-facebook(2.0.1).
  • league/oauth2-facebook 2.0.1 requires php ^5.6 || ^7.0 -> your php version (8.0.3) does not satisfy that requirement.

Todos os componentes (oauth2-facebook, oauth2-google, plates) do fornecedor league que tento instalar da esse problema.

A versão do meu php é a 8.0.3 como podem ver na mensagem e eu não consigo entender como uma versão superior a necessaria para o componente pode nao ter os requesitos minimos para roda-lo.

Caso alguem consiga ajudar ficarei grato.