python – No such configuration property: “schema.compatibility.level” when trying to initialise a kafka producer

I am using confluent-kafka.

My code is

producer = SimpleAvroProducer(producer_id="producer_1",
                              topic_name="events_topic",
                              broker_host= brkr_host,
                              broker_port= brkr_port,
                              schema_registry_host= schema_registry_host,
                              schema_registry_port= schema_registry_port,
                              key_schema_path=None,
                              value_schema_path=DIR_PATH + "/event_schema.avsc",
                              configurations={"schema.compatibility.level": "none",
                                              })

When running this , I am getting

E       cimpl.KafkaException: KafkaError{code=_INVALID_ARG,val=-186,str="No such configuration property: "schema.compatibility.level""}

even using the old avro.compatibility.level parameter also throws the same error

E       cimpl.KafkaException: KafkaError{code=_INVALID_ARG,val=-186,str="No such configuration property: "avro.compatibility.level""}

It works for other params like
"acks": "all","debug": "msg" but not compatibility level.

Please help me fix this. There are a lot of changes from the old schema and it neither forward nor backward compatible. I need to set it to None . Please help.!