python – Problem upgrading pip

I am running Ubuntu Mate 16.04 armhf on my Raspberry pi 3B.
I have read the forums for an answer to this question, although I have not found anything.
The default python version is python 2.7.12. I am having issues upgrading to the newest pip version.
This is the output of my terminal:
You are using pip version 8.1.1, however version 21.1.2 is available.
You should consider upgrading via the ‘pip install –upgrade pip’ command.

I then “run pip install –upgrade pip” and get the following error:
Could not find a version that satisfies the requirement pip3 (from versions: )
No matching distribution found for pip3.

What should I do? Thank you.