python3 – Pandas wants another version

When trying to import pandas, the following error message appears:
import_pandas_error,

I think it's related to my system's strange claim that pandas require a different version of Python, even though it's the version I'm using:

quinn@quinn-Lemur:~$ sudo -H pip3 install pandas
Requirement already satisfied: pandas in /usr/local/lib/python3.5/distpackages (0.25.3)
ERROR: Package 'pandas' requires a different Python: 3.5.2 not in '>=3.5.3'

quinn@quinn-Lemur:~$ python3 --version 
Python 3.5.2