I have a REST API called & # 39; getSessionState & # 39; , which is basically a backend API that gets some status information from a Redis server and returns to the clients.
Since the status data is stored on a Redis server, I will extend the sequence of the Redis data structure by one bit each time the function is called to avoid a key error.
One of my colleagues raises the question that it is, strictly speaking, a change in the state. Therefore, it should not be called "getSessionState", since "get" does not imply any changes to the backup data.
Is it a fair comment?
If so, what is a good alternative name to
My team generally uses Google's API design documentation https://cloud.google.com/apis/design/ as a design guide. However, I'm not sure if it covers the TTL aspect.