ubuntu – How do I make vacation autoresponding work for aliases?

We have an e-mail server on Ubuntu 18.04 running Postfix and Dovecot. How can I make vacation autoresponding work for our user’s aliases?

Example: Say our Deputy Librarian is theirname@ourlibrary.com and that’s also their user and e-mail account on the system, the one I sudo su theirname to in order to run the vacation program. But they also have an alias in /etc/aliases called deplib, so that e-mails sent to deplib@ourlibrary.com also get to them.

I have tried invoking vacation with -a deplib and then -a deplib@ourlibrary.com but neither worked. Only e-mails sent to theirname get the autoreply.

Any advice is greatly appreciated. I find e-mail administration to be somewhat over my head!

email – Forward mail as specified in virtual.db with aliases

I have set up alias all@mydomain.tld for every user on my linux server in this format.

all: username1,username2,username3

I also have set up virtual for forwarding all emails that come to server address to different mailservers.

username1@mydomain.tld    user1@gmail.com
username2@mydomain.tld    user2@gmail.com
username3@mydomain.tld    user3@gmail.com

When I send direct mail to username1@mydomain.tld it gets forwarded to gmail correctly, but when I send mail to all@mydomain.tld it is only stored on my server and not forwarded to other boxes. Is there any way to forward those mails ?

big sur – Why do aliases with words not expand in big sur?

I have some aliases in my ~/.bashrc and ~/.bash_profile (I tried with and without .bash_profile), they were both sourced.

alias ll=‘ls -l’ 
alias al=‘ls -ahl’

alias iridium=“~/git/iridium”
alias vscode=“Visual Studio Code” 

On Ubuntu, centos and fedora these would work fine.

Even on windows git bash I had long aliases to open games with the huge steam path.

But on big sur:

only the ls aliases work.

is there a reason for this?

I’m also sourcing these files from /etc/bashrc

Look at it in action:

 λ  cat ~/.bash_profile 
alias ll='ls -l'
alias al='ls -ahl'

alias vscode='Visual Studio Code'

alias batchelor="~/git/batcheloranator"
alias iridium="~/git/iridium"
alias chem="~/git/chemistry_stuff"
 chemistry_stuff:  (master)  
 λ  . ~/.bash_profile 
 chemistry_stuff:  (master)  
 λ  ll
total 64
-rw-r--r--   1 apple  staff   172 23 May 19:01 Dockerfile
drwxr-xr-x   3 apple  staff    96 23 May 16:57 __pycache__
drwxr-xr-x   4 apple  staff   128 24 May 16:01 apt_install
drwxr-xr-x   7 apple  staff   224 25 May 02:55 brew_install
-rw-r--r--   1 apple  staff   163 25 May 02:59 install.sh
-rw-r--r--   1 apple  staff  5680 25 May 02:59 read_chemical_components.py
-rw-r--r--   1 apple  staff   249 23 May 16:30 readme.md
-rw-r--r--   1 apple  staff    50 25 May 02:59 requirements.txt
drwxr-xr-x  11 apple  staff   352 23 May 16:30 test_images
-rw-r--r--   1 apple  staff  4152 23 May 16:30 test_read_chemical_components.py
 chemistry_stuff:  (master)  
 λ  al
total 80
drwxr-xr-x  15 apple  staff   480B 25 May 03:00 .
drwxr-xr-x   8 apple  staff   256B 24 May 17:01 ..
drwxr-xr-x  13 apple  staff   416B 25 May 02:59 .git
-rw-r--r--   1 apple  staff    29B 23 May 16:30 .gitattributes
-rw-r--r--   1 apple  staff    71B 23 May 16:30 .gitignore
-rw-r--r--   1 apple  staff   172B 23 May 19:01 Dockerfile
drwxr-xr-x   3 apple  staff    96B 23 May 16:57 __pycache__
drwxr-xr-x   4 apple  staff   128B 24 May 16:01 apt_install
drwxr-xr-x   7 apple  staff   224B 25 May 02:55 brew_install
-rw-r--r--   1 apple  staff   163B 25 May 02:59 install.sh
-rw-r--r--   1 apple  staff   5.5K 25 May 02:59 read_chemical_components.py
-rw-r--r--   1 apple  staff   249B 23 May 16:30 readme.md
-rw-r--r--   1 apple  staff    50B 25 May 02:59 requirements.txt
drwxr-xr-x  11 apple  staff   352B 23 May 16:30 test_images
-rw-r--r--   1 apple  staff   4.1K 23 May 16:30 test_read_chemical_components.py
 chemistry_stuff:  (master)  
 λ  cd iridium
bash: cd: iridium: No such file or directory
 chemistry_stuff:  (master)  
 λ  cd chem
bash: cd: chem: No such file or directory
 chemistry_stuff:  (master)  
 λ  open -a vscode
Unable to find application named 'vscode'

path aliases – [D8/Drupal8]: Pathauto pattern for a content type depending on a reference field?

This question is already asked here, but the answer selected does not work for Drupal8.

Description: There is a content-type, which has field, referencing taxonomy term. The term is in “Content class” dictionary. This term is used in views to filter the right content for the view. When a link in the view is clicked, it opens the node. This is OK.
So, it is needed pathauto to generate /Content class term/Content_title_name when this node is opened.

What is tried: (node:field_content_class:value)/(node:title). This is not accepted, produces error: Path pattern is using the following invalid tokens: (node:field_

The accepted (by Drupal) pattern: (node:field_content_class)/(node:title) generates alias, containing only the (node:title) part. The first component is empty.

This is made to not create separate content-types for nodes with the same fields.

debian – Is it possible to receive email for aliases of multiple domains on a single KVM?

I’m pretty new, so please do go easy on me. 🙂

Tl dr; is it possible to receive email for aliases of multiple domains on a single KVM?

I had a digital ocean server with multiple websites hosted on it, and needed email aliases of more than one of those domains. On several occasions, mail was not delivered, I believe it’s possible that this is because the corresponding domain did not use a PTR record (Could be wrong, I’m new, here.)

The PTR records with DO are tied to droplet names, so it seemed impossible to have PTR records for multiple domains, thus I was stuck with incomplete MX records and that may have been the cause of my undelivered mail.

I was thinking, there must be a way around this issue, besides renting another KVM.

please share your advice.

Best regards,
Glenn

Unable to use pathauto aliases for taxonomy terms in conjunction with views pages

I’m trying to set up pathauto aliases for a number of vocabularies to work alongside corresponding view pages. However, in doing so, I’m running into a 404s (“The requested page could not be found”) when visiting the view’s page path on the frontend. I suspect this is due to a conflict (and likely my misunderstanding of the relationship) between the views page paths and the taxonomy term path aliases. Note that I’m going to have a number of unique layouts and field sets for the various vocabularies, which is why I’m trying to create unique view pages and paths rather than the default taxonomy/term/% page.

An example taxonomy alias pattern is recipes/mealtime/(term:name).

Its corresponding view page path is recipes/mealtime/%, and it’s configured with the appropriate relationship (taxonomy field on the node) and contextual filter (term name with validation on the appropriate vocabulary). When I use the view configuration to preview with a particular term, I get the expected results.

The issue, however, is that when I visit a path on the frontend, e.g. /recipes/mealtime/lunch, I get a 404. Note that I’ve ensured that the path aliases have been generated.

What is the proper way to accomplish what I’ve described?

Many thanks in advance.

path aliases – How can I make my userid point to /user/*/ instead of pointing to /user/*/home?

Currently if I set my pathauto pattern to:
u/[user:account-name]

The result I receive is:
Alias: /u/michelleclark System Path: /user/5/home

I would like to recieve the result of:
Alias: /u/michelleclark System Path: /user/5/

Is there a way I can make it stop adding home on the end of the system path?

I am using a pre-made drupal distribution. I did ask in their issues section. I am not expecting a response anytime soon.

[edit]
I am using the open social distribution: https://www.drupal.org/project/social

Specifically the pre-built template from their github:
https://github.com/goalgorilla/social_template/

Three of my gmail aliases just stopped receiving email. HELP!

Three of my gmail aliases just stopped receiving email. I am able to send emails but as of yesterday, I have stopped receiving emails.

I have been using the aliases for over one year without any problems. My regular emails are working fine. I am just having problems with the aliases that have a domain name that is not gmail.

Any suggestions would be very appreciated.

Thank you!