angular – Angular6 ngIf creates empty element when false

I have a problem with Anguar6 and ngIf:

    <div class="card" *ngIf="pr.cat==='livres'" >
        <img src="https://stackoverflow.com/assets/img/images2.jpg">
        <div class="card-body">
            <h5 class="card-title"><b><u>Titre  :</u></b>{{pr.titreD}}</h5>
            <p class="card-text"><b><u>Description :</u></b>{{pr.description}}</p>
            <br><b><u>The donor :</u></b>{{pr.titre}}. {{pr.prenom}}  {{pr.nom}}<br>
            <b><u>Email :</u> </b>{{pr.email}}<br>
           <b><u>Téléphone: </u></b> {{pr.number}}<br>
            <a href="#" class="btn btn-primary">Click to view</a>
            <button type="submit" (click)="deleteproduit(i)" class="btn btn-primary">Supprimer</button>
        </div>
    </div>
</div>

The problem is, that angular creates an empty bloc with this comment in it:
(inspect element)(1)

When will the racists of Y!A admit that poverty, not genetics, is what creates the differences between minorities and whites?

Not only is what you say correct, but from a biological/scientific point of view race does not exist.

In fact there is as much genetic variety within a “race” as there is between races.

There are obvious differences (skin color being most readily apparent, but there are others – eye shape & other facial features, for example)  but these are very superficial (like eye or hair color within a race), leading to race as a social construct with no significant scientific basis.

Do your own search to find many articles such as:

http://sitn.hms.harvard.edu/flash/2017/science-gen…

Long established scientific fact is that all human beings originated from one area of the world (Africa as it is now known) which means we ALL have the same ancestry. Only those moving to latitudes further from direct sun lost melanin to become “white”.

There is really only one race – the Human Race…

networking – Danted on Debian creates strange listening port

I installed danted v1.4.2 on Debian 10 (buster) and I observe danted created few raw sockets and uses them for some purposes. The ss -f inet -an output looks the following way:

Netid   State    Recv-Q   Send-Q   Local Address:Port   Peer Address:Port    
???     UNCONN   0        0              0.0.0.0:1           0.0.0.0:*
???     UNCONN   0        0              0.0.0.0:1           0.0.0.0:*
(MORE UNRELATED DATA)

If I use old school netstat -an, I see “raw” where ss prints “???”. All the rest is identical. BTW, netstat prints state of the sockets as 7, while ss says it is UNCONN.

I spent quite a few hours googling for this behavior, but did not get any results. Danted works and forwards traffic as expected. The only thing is few raw sockets. The biggest issue with these raw sockets is their listening address. As I understand, they configured to listen on port 1 on all interfaces I have on my experimental server. Per my understanding, this is a security breach, since anyone could try to connect to it and I don’t have any good idea how to protect it.

  • Is this some error in danted configuration?
  • If not, is there any way to protect these ports from malicious connect attempts?
  • If answer on second question is yes, then – how?

magento 1.9 – Magento1 creates a new customer and sends an email

I have a function

public function createCustomer($data){

    $session = Mage::getSingleton('core/session');

    $key = Mage::helper('core')->getRandomString($length = 12);
    $uniqid = uniqid(mt_rand(), true);

    $websiteId = Mage::app()->getWebsite()->getId();
    $store = Mage::app()->getStore();
    $firstname = $data('name');
    $lastname = $data('name');
    $email = $data('email');
    $password = md5($key . $uniqid);

    $customer = Mage::getModel("customer/customer");
    $customer->setWebsiteId($websiteId)
         ->setStore($store)
         ->setFirstname($firstname)
         ->setLastname($lastname)
         ->setEmail($email)
         ->setPassword($password);
    $customer->save();
}

I want to send email when customer creates.
How can I call the Magento sender email?

Please help me!

Performance – program that creates a directory in C.

I have the following code that creates a directory in C. I have tested it several times, checked it a few times and it looks good at the moment (at least in my view).

What I really want to know is what bugs it has and how can I fix it? (Comparison with the mkdir Command from Linux)

#include "ourhdr.h"
#include 
#include 
#include 


int main(int argc, char **argv)
{

    if(argc != 2)
    {
        printf("./i78 /locatie/nume_director sau ./i78 nume_directorn");
        return 1;
    }

    char buff(PATH_MAX);
    strcpy(buff,argv(1));

    if (mkdir(buff,S_IRWXU|S_IRWXG|S_IRWXO)<0)
    {   
    printf("%s: cannot create directory '%s': File existsn",argv(0),buff);
    }
    else

    printf("n Creare director (%s)n",buff);


}

WhatsApp – Auto Creates thumbnails in the DCIM directory – Cannot be stopped

How do I control which images I see when I click the camera icon in WhatsApp? Which app calls this "latest"? Can WhatsApp point out that only the DCIM directory is shown on my SD card?

After installing WhatsApp, grant permission to use the camera and your files. Images are usually saved in the DCIM folder. So if you want to take a picture with WhatsApp with the camera, WhatsApp will display pictures from the default folder where pictures are stored due to access to your storage (although this is not the folder where WhatsApp stores its pictures) other locations. What follows is the creation of thumbnails (if they have not yet been created) in case you want to display / use other images.

If you don't deny both camera and memory privileges, you have no control. If you deny permission to save, you can use other files, not just pictures.

How can I prevent the old thumbnails from appearing again in the directory Internal Storage / DCIM / .thumbnails when the camera app is started via WhatsApp?

Regardless of whether it is WhatsApp or another app, you cannot prevent this as long as you have permissions for your storage and / or your camera. I think MediaStorage will recreate them in any way, if not immediately, at least the next time you restart or use the camera.

Deja Dup always creates the first backup

I am using MATE Ubuntu 16.04 on an ASUS x-550LA and am trying to backup to an external hard drive via USB.
Every time I start Deja Dup I get "Make First Copy".

This is what I find when I open the external hard drive there are 149 such volumes.
***** / duplicity-full.20200502T220644Z.vol1.difftar.gz

When I try to restore a test folder to "Previous Version", "No backups" is reported.

I would be very happy about any help as no similar answers adequately cover my problem.

The SharePoint "Export to Excel" list creates a table that does not retain the correct column types when you re-import it into SharePoint

Desired behavior

Export a SharePoint list to a CSV or Excel file in a format that can be imported back into SharePoint as a list with all correctly formatted column types and values.

The reason why this functionality is required is to ensure that backed up SharePoint lists can be restored quickly and easily.

Current behavior

Import a file that was created by clicking Export to Excel from a SharePoint list (which prompts you to download one) .iqy File that can be saved as when opened .xlsx File) leads to a list in which column types are wrong and values ​​are not formatted correctly.

What I tried

Follow the instructions in the following article to create a SharePoint list from the exported Excel document:

Create a list based on a table

However, the article has this limitation:

Note: Typically, the columns on the SharePoint site are set up based on the data type they contain. However, after importing a list, you should check the columns and dates to make sure everything was imported as expected. For example, you might want to specify that a column contains a currency, not just a number. To view or change the list settings, open the list and select List Settings from the Settings menu.

In particular, these are the results I'm getting (the exclamation point ! shows wrong column type):

+--------------------------------------+------------------------+------------------------+
|                Column                |      Original Type     |    Imported Type       |
+--------------------------------------+------------------------+------------------------+
| Title                                | Single line of text    | Single line of text    |
| MySingleLineOfTextColumn             | Single line of text    | Single line of text    |
| MyMultipleLinesOfTextColumn          | Multiple lines of text | Multiple lines of text |
| MyLocationColumn                     | Location               | Single line of text !  |
| MyNumberColumn                       | Number                 | Number                 |
| MyYesNoColumn                        | Yes/No                 | Yes/No                 |
| MyPersonColumn                       | Person or Group        | Single line of text !  |
| MyDateColumn                         | Date and Time          | Date and Time          |
| MyChoiceColumnMultiWithSelections    | Choice                 | Single line of text !  |
| MyChoiceColumnMultiWithoutSelections | Choice                 | Single line of text !  |
| MyChoiceColumnSingleWithSelection    | Choice                 | Single line of text !  |
| MyChoiceColumnSingleWithoutSelection | Choice                 | Single line of text !  |
| MyHyperlinkColumn                    | Hyperlink or Picture   | Hyperlink or Picture   |
| MyPictureColumn                      | Hyperlink or Picture   | Hyperlink or Picture   |
| MyCurrencyColumn                     | Currency               | Currency               |
| Modified                             | Date and Time          | Date and Time          |
| Created                              | Date and Time          | Date and Time          |
| Created By                           | Person or Group        | Person or Group        |
| Modified By                          | Person or Group        | Person or Group        |
+--------------------------------------+------------------------+------------------------+

So the following columns are of the wrong type:

+--------------------------------------+------------------------+------------------------+
|                Column                |      Original Type     |    Imported Type       |
+--------------------------------------+------------------------+------------------------+
| MyLocationColumn                     | Location               | Single line of text !  |
| MyPersonColumn                       | Person or Group        | Single line of text !  |
| MyChoiceColumnMultiWithSelections    | Choice                 | Single line of text !  |
| MyChoiceColumnMultiWithoutSelections | Choice                 | Single line of text !  |
| MyChoiceColumnSingleWithSelection    | Choice                 | Single line of text !  |
| MyChoiceColumnSingleWithoutSelection | Choice                 | Single line of text !  |
+--------------------------------------+------------------------+------------------------+

Strange, Person or Group works if the values ​​are automatically added by SharePoint, e.g. Created By and Modified By Columns, but not if I searched for and selected a user in one Person or Group Pillar.

If I change the column type of all columns that should be selection columns to "Selection" in the "List Settings" area (with the relevant settings "Check box (allow multiple selections") and manually define all available options), then the values ​​in the list frontend are displayed correctly.

So what was shown at Choice1;#Choice2;#Choice3 is now displayed as Choice1, Choice2, Choice3 and the relevant selections are "checked" when editing the elements.

It is not possible to change the column type of the columns that should have types of Location and Person or Grouphowever, because they are both now Single line of text Art.

question

What must all column type values ​​be for them to be imported correctly into SharePoint?

Or, more precisely, how should the values ​​be exported so that they can be correctly imported back into SharePoint?

PS …

I noticed it when exporting the list and opening the result .iqy File, I get the message:

The table contains a string that is too long to display Excel. If you edit the long value, some data may be lost.

So that's why Location The column value is truncated. How can you work around this problem when backing up content that contains a location?

Plugins – .com creates an automated link in the post

When we write "example.com" in classic mode, an automated link is created as follows:

 
     example
     .
     com
 

What I tried:

  • I searched for it and found it class="vglnk" comes from Discus Plugin and we have to tick some options to do that. But I do not want to to do this because of the safety of some basic operations.
  • I tried going over HTML entity after & # 39; point & # 39; to search. so that we can use this sign so WordPress doesn't take it as a link. But this sign converts to & # 39;. & # 39; self

  • I tried to add this link example.com..It did not work

  • I tried to add
    example.com
    but it still doesn't work

I want simple text from example.com, please help me.