dhcp – How can I set IPv6 addresses pool range and lease time in OpenWrt?

I would like to change IPv6 addresses pool range on my router running OpenWrt. I know how to do it with IPv4 but I cannot find information how to do it with IPv6 addresses. The second question is how to manipulate lease time for ipv6. I tried to set ra_useleasetime to use the same lease time as for IPv4, but it doesn’t work. Do you have any idea how to do it? Thank you in advance for any help.

networking – Turning off second DHCP makes devices disappear

I have a modem with an included WIFI router and LAN ports.
To that modem, I attached an ASUS WIFI router and a NAS.
To the ASUS router, I attached a sound receiver.

I had some issues because of both the modem and the router running a DHCP server.
Therefore I turned off the DHCP at the ASUS router because the modem is serving IP addresses. But now the sound receiver does suddenly disappear from the network.

My question now is what is the best configuration?

Should I run the DHCP on the modem or on the router?
Or on both with a defined, not overlapping, IP range?

Also: I found out that when the ASUS is connected to the modem via the WAN port I experience massive amounts of package loss. That is not the case when I connect both via the LAN port.

linux – DHCP not assigning IP to network interface

Running dhcpd from CLI with configuration file on /etc/dhcp/dhcpd.conf, returns:

No subnet declaration for enp2s0 (no IPv4 addresses).
** Ignoring requests on enp2s0.  If this is not what
   you want, please write a subnet declaration
   in your dhcpd.conf file for the network segment
   to which interface enp2s0 is attached. **


Not configured to listen on any interfaces!

but i can’t really get how is this configuration “write a subnet declaration in your dhcpd.conf file” supposed to be. My config file is the following:

# minimal sample /etc/dhcp/dhcpd.conf
default-lease-time 600;
max-lease-time 7200;
authoritative;
subnet 192.166.1.0 netmask 255.255.255.0 {
 range 192.166.1.150 192.166.1.200;
}
#on a request by the dhcp client, the dhcp server gives those net parameters.

The laptop is connected to a switch, that does not have any dhcp. Any help on setting up DHCP server?

windows server 2012 r2 – forcing clients to receive their ips from dhcp

i have a problem with my clients, to express it let me describe my network first.
my clients usually connect to L2 cisco switches and then the core switch (6708) -the connection between L2 and core setteled via vlan-, after that they can access the dhcp server (Win-server 2012) for receiving ip, it is to be noted that i have identified the dhcp server for them via “ip helper address” on my core switch.
now the problem is here, some clients usually set manuall ips for themselves and i need to force them to receive ip from the dhcp server. and if a client set ip manually, he can not access to anywhere.
can i do any thing for this problem?
thanks for helping.

networking – No DHCP Offer Through Switch

Issue

Ubuntu will not connect to my network when using a switch. It will connect if wired directly into the router.

My wife has ‘asked’ that I don’t have cables in the hallway anymore (especially with a baby that should be crawling soon) and the router needs to stay where it is, so connecting directly to the router is not an option.

Summary

I am new at Ubuntu/Linux, and I am now way over my head. Shocking, I know. I’ve been at this for a couple of weeks now, and have scoured the internet for an answer with no luck.
Hopefully I haven’t missed something and are wasting your time.

I have a Ubuntu computer that I am using for a home server.
It connects to the network without a hitch if I connect it straight into the router.
It is refusing to connect to the internet when I put a switch between it and the router.
The network client is stuck on “connecting” and gives ‘activation of network connection failed.’
As far as I can tell, the server seems to be having trouble getting a DHCP response.

I’m hoping someone who sees this can help point me in the correct direction. Okay, let’s not kid ourselves, I’m hoping someone knows the answer, but I’ll take what I can get. Happy to provide any more info.

Network Map

Network Map

In this image, all red lines are lines that don’t work and the green is the line that does work.

Specs

  • OS: Ubuntu 20.04.2 LTS (was on Ubuntu 16.something, same results)
  • Processor: Intel Xeon(R) CPU X3450 @ 2.67GHz x 8
  • NIC 1 (AKA enp4s0): Intel Corporation 82574L Gigabit Network Connection
  • NIC 2 (AKA enp5s0): Intel Corporation 82574L Gigabit Network Connection
  • Router: Arris NVG468MQ (Had a different router a couple weeks ago. Same results)
  • Switch: Netgear GS305 (Also tried a TP-Link TL-SGG105 and a TP-Link SF1008D)

Notes

  • Manually setting the IP address does not fix the issue.
  • Both of the NIC cards have the same issue.
  • All ethernet cables are cat 5e or cat 6 cables
  • Issue presents itself on installed OSs (20.04.2 and 16.something), a pupply linux live CD, and an ubuntu 20.04.2 live USB.
  • For the most part, the server does not show up in any of the router’s admin pages/device lists
  • After the following command, which someone says makes the network interface ‘promiscuous,’ the server showed up in the router’s devices list, but the network still didn’t work: “`$ sudo tcpdump -n udp port 68 -vv“`
  • Currently on a brand new, fully updated installation
  • Server has been rebooted multiple times
  • “dhclient -r” has no noticable affect
  • “dhclient enp4s0” has no noticable affect

Terminal Results

$ lspci | grep Ethernet

04:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
05:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection

$ cat /etc/NetworkManager/NetworkManager.conf

(main)
plugins=ifupdown,keyfile
(ifupdown)
managed=false
(device)
wifi.scan-rand-mac-address=no

$ sudo dhclient -v enp4s0

Internet Systems Consortium DHCP Client 4.4.1
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
Listening on LPF/enp4s0/90:e6:ba:92:24:94
Sending on LPF/enp4s0/90:e6:ba:92:24:94
Sending on Socket/fallback
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 3 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 3 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 4 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 7 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 10 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 16 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 20 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 18 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 21 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 12 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 20 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 14 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 14 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 13 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 16 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 16 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 17 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 12 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 9 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 13 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 7 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 11 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 11 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 8 (xid=0xb03b7843)
DHCPDISCOVER on enp4s0 to 255.255.255.255 port 67 interval 6 (xid=0xb03b7843)
No DHCPOFFERS received.
No working leases in persistent database – sleeping.

$ sudo tail -f /var/log/syslog

(sudo) password for andrew:
May 30 12:57:48 FemmiServ avahi-daemon(644): Withdrawing address record for
fe80::6e01:80b5:40b3:8ccd on enp4s0.
    
    May 30 12:57:48 FemmiServ avahi-daemon(644): Leaving mDNS multicast group on interface
    enp4s0.IPv6 with address fe80::6e01:80b5:40b3:8ccd.
    May 30 12:57:48 FemmiServ avahi-daemon(644): Interface enp4s0.IPv6 no longer relevant for mDNS.
    May 30 12:57:49 FemmiServ NetworkManager(648): <info> (1622404669.0053) dhcp4 (enp4s0):
    canceled DHCP transaction
    May 30 12:57:49 FemmiServ NetworkManager(648): <info> (1622404669.0054) dhcp4 (enp4s0): state
    changed timeout -> done
    May 30 12:57:49 FemmiServ dbus-daemon(647): (system) Activating via systemd: service
    name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by
    ':1.12' (uid=0 pid=648 comm="/usr/sbin/NetworkManager --no-daemon " label="unconfined")
    May 30 12:57:49 FemmiServ systemd(1): Starting Network Manager Script Dispatcher Service...
    May 30 12:57:49 FemmiServ dbus-daemon(647): (system) Successfully activated service
    'org.freedesktop.nm_dispatcher'
    May 30 12:57:49 FemmiServ systemd(1): Started Network Manager Script Dispatcher Service.
    May 30 12:57:58 FemmiServ systemd(1): NetworkManager-dispatcher.service: Succeeded.
    May 30 13:01:13 FemmiServ dbus-daemon(647): (system) Activating via systemd: service
    name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.76'
    (uid=1000 pid=1909 comm="gnome-control-center network " label="unconfined")
    May 30 13:01:13 FemmiServ systemd(1): Starting Hostname Service...
    May 30 13:01:13 FemmiServ dbus-daemon(647): (system) Successfully activated service
    'org.freedesktop.hostname1'
    May 30 13:01:13 FemmiServ systemd(1): Started Hostname Service.
    
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6479) audit: op="connection-
    update" uuid="3f27339b-ac78-3932-a93a-0348c70a25af" name="Wired connection 1"
    
    args="connection.timestamp,ipv6.method" pid=1909 uid=1000 result="success"
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6486) policy: auto-activating
    connection 'Wired connection 1' (3f27339b-ac78-3932-a93a-0348c70a25af)
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6529) device (enp4s0):
    Activation: starting connection 'Wired connection 1' (3f27339b-ac78-3932-a93a-0348c70a25af)
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6531) device (enp4s0): state
    change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6539) manager:
    NetworkManager state is now CONNECTING
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6543) device (enp4s0): state
    change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6558) device (enp4s0): state
    change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
    May 30 13:01:21 FemmiServ NetworkManager(648): <info> (1622404881.6562) dhcp4 (enp4s0):
    activation: beginning transaction (timeout in 45 seconds)
    May 30 13:01:23 FemmiServ avahi-daemon(644): Joining mDNS multicast group on interface
    enp4s0.IPv6 with address fe80::92e6:baff:fe92:2494.
    May 30 13:01:23 FemmiServ avahi-daemon(644): New relevant interface enp4s0.IPv6 for mDNS.
    May 30 13:01:23 FemmiServ avahi-daemon(644): Registering new address record for
    fe80::92e6:baff:fe92:2494 on enp4s0.*.
    May 30 13:01:43 FemmiServ dbus-daemon(867): (session uid=1000 pid=867) Activating via systemd:
    service name='org.bluez.obex' unit='dbus-org.bluez.obex.service' requested by ':1.136' (uid=1000
    pid=1909 comm="gnome-control-center network " label="unconfined")
    May 30 13:01:43 FemmiServ systemd(1): systemd-hostnamed.service: Succeeded.
    May 30 13:01:43 FemmiServ systemd(801): Starting Bluetooth OBEX service...
    May 30 13:01:43 FemmiServ obexd(2604): OBEX daemon 5.53
    May 30 13:01:43 FemmiServ dbus-daemon(867): (session uid=1000 pid=867) Successfully activated
    service 'org.bluez.obex'
    May 30 13:01:43 FemmiServ systemd(801): Started Bluetooth OBEX service.
    May 30 13:02:03 FemmiServ dbus-daemon(647): (system) Activating via systemd: service
    name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by
    ':1.12' (uid=0 pid=648 comm="/usr/sbin/NetworkManager --no-daemon " label="unconfined")
    May 30 13:02:03 FemmiServ systemd(1): Starting Network Manager Script Dispatcher Service...
    
    May 30 13:02:03 FemmiServ dbus-daemon(647): (system) Successfully activated service
    'org.freedesktop.nm_dispatcher'
    May 30 13:02:03 FemmiServ systemd(1): Started Network Manager Script Dispatcher Service.
    May 30 13:02:06 FemmiServ NetworkManager(648): <warn> (1622404926.9662) dhcp4 (enp4s0):
    request timed out
    May 30 13:02:06 FemmiServ NetworkManager(648): <info> (1622404926.9662) dhcp4 (enp4s0): state
    changed unknown -> timeout
    May 30 13:02:06 FemmiServ NetworkManager(648): <info> (1622404926.9663) device (enp4s0): state
    change: ip-config -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')
    May 30 13:02:06 FemmiServ NetworkManager(648): <info> (1622404926.9673) manager:
    NetworkManager state is now DISCONNECTED
    May 30 13:02:06 FemmiServ NetworkManager(648): <warn> (1622404926.9696) device (enp4s0):
    Activation: failed for connection 'Wired connection 1'
    May 30 13:02:06 FemmiServ NetworkManager(648): <info> (1622404926.9704) device (enp4s0): state
    change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
    May 30 13:02:06 FemmiServ avahi-daemon(644): Withdrawing address record for
    fe80::92e6:baff:fe92:2494 on enp4s0.

$ journalctl

-- Logs begin at Sun 2021-05-30 12:30:22 PDT, end at Sun 2021-05-30 12:57:49 PD>
    May 30 12:30:22 FemmiServ kernel: microcode: microcode updated early to revisio>
    May 30 12:30:22 FemmiServ kernel: Linux version 5.8.0-43-generic (buildd@lcy01->
    May 30 12:30:22 FemmiServ kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.8.0->
    May 30 12:30:22 FemmiServ kernel: KERNEL supported cpus:
    May 30 12:30:22 FemmiServ kernel: Intel GenuineIntel
    May 30 12:30:22 FemmiServ kernel: AMD AuthenticAMD
    May 30 12:30:22 FemmiServ kernel: Hygon HygonGenuine
    May 30 12:30:22 FemmiServ kernel: Centaur CentaurHauls
    May 30 12:30:22 FemmiServ kernel: zhaoxin Shanghai
    May 30 12:30:22 FemmiServ kernel: x86/fpu: x87 FPU will use FXSAVE
    May 30 12:30:22 FemmiServ kernel: BIOS-provided physical RAM map:
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x0000000000000000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x000000000009fc00-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000000e4000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x0000000000100000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf77e000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf780000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf78e000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf7dc000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000e0000000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000fee00000-0x00000000>
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000ffe00000-0x00000000>
    lines 1-23...skipping...
    -- Logs begin at Sun 2021-05-30 12:30:22 PDT, end at Sun 2021-05-30 12:57:49 PDT. --
    May 30 12:30:22 FemmiServ kernel: microcode: microcode updated early to revision 0xa, date = 2018-
    05-08
    May 30 12:30:22 FemmiServ kernel: Linux version 5.8.0-43-generic (buildd@lcy01-amd64-018) (gcc
    (Ubuntu 9.3.0->
    May 30 12:30:22 FemmiServ kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.8.0-43-generic
    root=UUID=42c3d73b->
    May 30 12:30:22 FemmiServ kernel: KERNEL supported cpus:
    May 30 12:30:22 FemmiServ kernel: Intel GenuineIntel
    May 30 12:30:22 FemmiServ kernel: AMD AuthenticAMD
    May 30 12:30:22 FemmiServ kernel: Hygon HygonGenuine
    May 30 12:30:22 FemmiServ kernel: Centaur CentaurHauls
    May 30 12:30:22 FemmiServ kernel: zhaoxin Shanghai
    
    May 30 12:30:22 FemmiServ kernel: x86/fpu: x87 FPU will use FXSAVE
    May 30 12:30:22 FemmiServ kernel: BIOS-provided physical RAM map:
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x0000000000000000-0x000000000009fbff)
    usable
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x000000000009fc00-0x000000000009ffff)
    reserved
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000000e4000-0x00000000000fffff)
    reserved
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x0000000000100000-0x00000000bf76ffff)
    usable
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf77e000-0x00000000bf77ffff) type
    9
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf780000-0x00000000bf78dfff)
    ACPI data
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf78e000-0x00000000bf7dbfff)
    ACPI NVS
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000bf7dc000-0x00000000bfffffff)
    reserved
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000e0000000-0x00000000efffffff)
    reserved
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000fee00000-0x00000000fee00fff)
    reserved
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x00000000ffe00000-0x00000000ffffffff)
    reserved
    May 30 12:30:22 FemmiServ kernel: BIOS-e820: (mem 0x0000000100000000-0x000000043fffffff)
    usable
    May 30 12:30:22 FemmiServ kernel: NX (Execute Disable) protection: active
    May 30 12:30:22 FemmiServ kernel: SMBIOS 2.6 present.
    May 30 12:30:22 FemmiServ kernel: DMI: System manufacturer System Product Name/P7F-E, BIOS
    0303 09/02/2009
    May 30 12:30:22 FemmiServ kernel: tsc: Fast TSC calibration failed
    May 30 12:30:22 FemmiServ kernel: e820: update (mem 0x00000000-0x00000fff) usable ==> reserved
    May 30 12:30:22 FemmiServ kernel: e820: remove (mem 0x000a0000-0x000fffff) usable
    May 30 12:30:22 FemmiServ kernel: last_pfn = 0x440000 max_arch_pfn = 0x400000000
    May 30 12:30:22 FemmiServ kernel: MTRR default type: uncachable
    May 30 12:30:22 FemmiServ kernel: MTRR fixed ranges enabled:
    May 30 12:30:22 FemmiServ kernel: 00000-9FFFF write-back
    May 30 12:30:22 FemmiServ kernel: A0000-BFFFF uncachable
    May 30 12:30:22 FemmiServ kernel: C0000-CBFFF write-protect
    May 30 12:30:22 FemmiServ kernel: CC000-DFFFF uncachable
    May 30 12:30:22 FemmiServ kernel: E0000-E7FFF write-through
    May 30 12:30:22 FemmiServ kernel: E8000-FFFFF write-protect
    May 30 12:30:22 FemmiServ kernel: MTRR variable ranges enabled

$ sudo lshw -C network

*-network
    description: Ethernet interface
    product: 82574L Gigabit Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:04:00.0
    logical name: enp4s0
    version: 00
    serial: 90:e6:ba:92:24:94
    size: 1Gbit/s
    capacity: 1Gbit/s
    width: 32 bits
    
    clock: 33MHz
    capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt
    100bt-fd 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full
    firmware=1.8-0 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
    resources: irq:18 memory:fbce0000-fbcfffff ioport:cc00(size=32) memory:fbcdc000-fbcdffff
    *-network
    description: Ethernet interface
    product: 82574L Gigabit Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:05:00.0
    logical name: enp5s0
    version: 00
    serial: 90:e6:ba:92:26:5f
    capacity: 1Gbit/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt
    100bt-fd 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=1.8-
    0 latency=0 link=no multicast=yes port=twisted pair
    resources: irq:19 memory:fbe00000-fbe1ffff ioport:dc00(size=32) memory:fbdfc000-fbdfffff
    andrew@FemmiServ:~$ ip ro
    default dev enp5s0 scope link metric 1003 linkdown
    169.254.0.0/16 dev enp5s0 proto kernel scope link src 169.254.7.132 linkdown

$ systemctl

     UNIT LOAD ACTIV>
        proc-sys-fs-binfmt_misc.automount loaded activ>
        dev-loop7.device loaded activ>
        sys-devices-pci0000:00-0000:00:1b.0-sound-card0.device loaded activ>
        sys-devices-pci0000:00-0000:00:1c.6-0000:04:00.0-net-enp4s0.device loaded activ>
        sys-devices-pci0000:00-0000:00:1c.7-0000:05:00.0-net-enp5s0.device loaded activ>
        sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda1.device loaded
        activ>
        sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda.device loaded activ>
        sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:1-0:0:1:0-block-sdb.device loaded activ>
        sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:0-1:0:0:0-block-sdc.device loaded activ>
        sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:1-1:0:1:0-block-sdd-sdd1.device loaded
        activ>
        sys-devices-pci0000:00-0000:00:1f.2-ata2-host1-target1:0:1-1:0:1:0-block-sdd.device loaded activ>
        sys-devices-pci0000:00-0000:00:1f.5-ata3-host2-target2:0:0-2:0:0:0-block-sde-sde1.device loaded
        activ>
        sys-devices-pci0000:00-0000:00:1f.5-ata3-host2-target2:0:0-2:0:0:0-block-sde.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS10.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS11.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS12.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS13.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS14.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS15.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS16.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS17.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS18.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS19.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS2.device loaded activ>
        
        sys-devices-platform-serial8250-tty-ttyS20.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS21.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS22.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS23.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS24.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS25.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS26.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS27.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS28.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS29.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS3.device loaded activ>
        sys-devices-platform-serial8250-tty-ttyS30.device loaded activ>
        
        andrew@FemmiServ:~$ ps aux |egrep wpa|com
        root 68 0.0 0.0 0 0 ? S May30 0:00 (kcompactd0)
        root 686 0.0 0.0 13688 4880 ? Ss May30 0:00 /sbin/wpa_supplicant -u -s -O
        /run/wpa_supplicant
        andrew 1414 0.0 0.1 282780 29756 ? Ssl May30 0:00 /usr/libexec/gsd-wacom
        andrew 14511 0.0 0.0 17672 724 pts/0 S+ 15:04 0:00 grep -E --color=auto wpa|com
        andrew@FemmiServ:~$ sudo tcpdump -v
        tcpdump: listening on enp4s0, link-type EN10MB (Ethernet), capture size 262144 bytes
        15:13:07.192454 IP (tos 0x0, ttl 1, id 50360, offset 0, flags (none), proto UDP (17), length 202)
        50.39.173.111.51922 > 239.255.255.250.1900: UDP, length 174
        15:13:08.206626 IP (tos 0x0, ttl 1, id 50361, offset 0, flags (none), proto UDP (17), length 202)
        50.39.173.111.51922 > 239.255.255.250.1900: UDP, length 174
        15:13:09.208272 IP (tos 0x0, ttl 1, id 50362, offset 0, flags (none), proto UDP (17), length 202)
        50.39.173.111.51922 > 239.255.255.250.1900: UDP, length 174
        15:13:10.213948 IP (tos 0x0, ttl 1, id 50363, offset 0, flags (none), proto UDP (17), length 202)
        50.39.173.111.51922 > 239.255.255.250.1900: UDP, length 174
        15:13:11.108123 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:13:17.128842 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:13:23.149624 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:13:28.638930 IP (tos 0xc0, ttl 64, id 0, offset 0, flags (DF), proto UDP (17), length 321)
        0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 90:e6:ba:92:24:94 (oui
        Unknown), length 293, xid 0xaa2ba215, secs 836, Flags (none)
        Client-Ethernet-Address 90:e6:ba:92:24:94 (oui Unknown)
        Vendor-rfc1048 Extensions
        Magic Cookie 0x63825363
        DHCP-Message Option 53, length 1: Discover
        Client-ID Option 61, length 7: ether 90:e6:ba:92:24:94
        Parameter-Request Option 55, length 17:
        Subnet-Mask, Time-Zone, Domain-Name-Server, Hostname
        Domain-Name, MTU, BR, Classless-Static-Route
        Default-Gateway, Static-Route, YD, YS
        NTP, Option 119, Classless-Static-Route-Microsoft, Option 252
        RP
        MSZ Option 57, length 2: 576
        Requested-IP Option 50, length 4: 192.168.254.24
        Hostname Option 12, length 9: "FemmiServ"
        15:13:29.170117 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:13:35.190450 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        
        0.0.0.0, length 46
        15:13:41.212982 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:13:47.231609 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:13:53.251508 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:13:59.271474 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        15:14:05.290307 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.144.200 (Broadcast) tell
        0.0.0.0, length 46
        ^C
        15 packets captured
        15 packets received by filter
        0 packets dropped by kernel

$ sudo tcpdump -n udp port 68 -vv

tcpdump: listening on enp4s0, link-type EN10MB (Ethernet), capture size 262144 bytes
    15:17:46.522511 IP (tos 0xc0, ttl 64, id 0, offset 0, flags (DF), proto UDP (17), length 321)
    0.0.0.0.68 > 255.255.255.255.67: (udp sum ok) BOOTP/DHCP, Request from 90:e6:ba:92:24:94,
    length 293, xid 0xf259977b, secs 1094, Flags (none) (0x0000)
    Client-Ethernet-Address 90:e6:ba:92:24:94
    Vendor-rfc1048 Extensions
    Magic Cookie 0x63825363
    DHCP-Message Option 53, length 1: Discover
    Client-ID Option 61, length 7: ether 90:e6:ba:92:24:94
    Parameter-Request Option 55, length 17:
    Subnet-Mask, Time-Zone, Domain-Name-Server, Hostname
    Domain-Name, MTU, BR, Classless-Static-Route
    Default-Gateway, Static-Route, YD, YS
    NTP, Option 119, Classless-Static-Route-Microsoft, Option 252
    RP
    MSZ Option 57, length 2: 576
    Requested-IP Option 50, length 4: 192.168.254.24
    Hostname Option 12, length 9: "FemmiServ"
    15:18:50.758747 IP (tos 0xc0, ttl 64, id 0, offset 0, flags (DF), proto UDP (17), length 321)
    0.0.0.0.68 > 255.255.255.255.67: (udp sum ok) BOOTP/DHCP, Request from 90:e6:ba:92:24:94,
    length 293, xid 0x355ce1b5, secs 1158, Flags (none) (0x0000)
    Client-Ethernet-Address 90:e6:ba:92:24:94
    Vendor-rfc1048 Extensions
    Magic Cookie 0x63825363
    DHCP-Message Option 53, length 1: Discover
    Client-ID Option 61, length 7: ether 90:e6:ba:92:24:94
    Parameter-Request Option 55, length 17:
    Subnet-Mask, Time-Zone, Domain-Name-Server, Hostname
    Domain-Name, MTU, BR, Classless-Static-Route
    Default-Gateway, Static-Route, YD, YS
    NTP, Option 119, Classless-Static-Route-Microsoft, Option 252
    RP
    MSZ Option 57, length 2: 576
    Requested-IP Option 50, length 4: 192.168.254.24
    Hostname Option 12, length 9: "FemmiServ"
    ^C
    2 packets captured
    2 packets received by filter
    0 packets dropped by kernel

linux – On Ubuntu 20.04, DHCP keeps overwriting static address assigned via Network Manager

I have properly configured the interface with this yaml file:

network:
  renderer: networkd
  ethernets:
    ens33:
      addresses: (192.168.174.131/24)
      gateway4: 192.168.174.2
      nameservers:
        addresses: (8.8.8.8, 8.8.4.4)
      routes:
        - to: 192.168.174.0
          via: 192.168.173.131
    lo:
      addresses: (127.0.0.1/24,0.0.0.0/24)

and the route table shows the access to the VMNAT8 address (which is 192.168.174.20):

my_env) ubuntu@ubuntu2010:/etc/netplan$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         _gateway        0.0.0.0         UG    0      0        0 ens33
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
192.168.174.0   0.0.0.0         255.255.255.0   U     0      0        0 ens33

The problem is after a period of time, an ipv6 address is assigned to ens33, as if the dhclient ran and ignored the static configuration.

The question is how to prevent this from happening? I have not found a solution suggested on the various sites which describe related issues.

dhcp – Change my hotspot tethering Gateway IP address

I’m having a problem using multiple cellphones as cameras into the app IP Webcam. I use them with the USB Tethering since it has best image and latency quality, so after plugging them into the computer and enabling the USB tethering I need to put the Gateway IP that android creates in the USB tethering and here it starts the problem:

Every android when tethering uses the same Gateway IP (192.168.42.129) and there is no way I can change it natively, so when I try to connect any other cellphone it will use the same Gateway IP. What I need to do is find a way to change the IP of one of my cellphones (one is rooted and the other one it’s not rooted) so I can use both cellphones as webcams.

I’ve already tried using DroidCamX that can connect without tethering or via LAN yet it’s latency and quality is much inferior to the IP Webcam. As well I found this thread yet I need to be agile to set up the cameras (open Android SDK and do all the right commands) and I can’t waste computer processing with the Android SDK running. If you think there is any other solution to my problem let me know.

As a disclaimer I want to warn you that I’m pretty new to android coding, I have no idea how to edit android source code and implement it, even wich tools to use. So if you could just point me out any manual or tutorial or even show me how to do it I would love to learn it. Thank you, guys!

windows server 2012 r2 – DHCP DDNS Updates to secondary DNS sever

I am trying to configure DDNS updates from the ISC DHCP server to the zone that is hosted on the windows server, in the dhcpd.conf I have zone section a below

zone example.com.
{
primary 192.168.0.45;
secondary 192.168.0.47;
}
It is working fine as expected for the primary DNS server but I have noticed that DHCP is not sending any DDNS updates to the secondary DNS server(192.168.0.47) of the zone when the primary is down for some reason, is this the expected behavior?

Getting below error
Unable to add forward map from n54c5-000001.example.com to 192.168.0.86: NOTIMP
where 192.168.0.86 is the client IP offered by the DHCP server

I tried checking the tcpdump from my dhcp server, I can see the traffic to the secondary DNS server but the zone is not getting any update, Please guide me if need to add any configuration line in dhcpd.conf to support sending the DDNS updates for secondary server also or any setting to be configured on the windows secondary server

Does anyone have any idea/experience of DDNS flow when the primary DNS server is down

Thanks in Advance

CISCO Configuration. DHCP & VLAN configured. But can’t ping other VLAN clients

I have created a network testing lab with CISCO Packet Tracer. I have performed the following to get a DHCP and VLAN (with Trucking) working:

  1. Configured Router interfaces (g0/0 + g0/0.10-0.50)
  2. Configured DHCP settings on Router
  3. Enabled Trunk on Router
  4. Configured VLAN on Switch
  5. Enabled Trunk on Switch

Below I post the >show run< for the router and the Switch. Workstations can gain an DHCP IP address, and VLAN segregation is working.

Workstations can ping the router but can’t ping other workstations on separate VLAN networks.

Router Configuration

shanelab#show run
Building configuration...

Current configuration : 2184 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname shanelab
!
!
!
enable secret 5 $1$mERr$xqDCepYvK4SAD6V0cxKQ3.
!
!
ip dhcp excluded-address 192.168.10.1 192.168.10.10
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp excluded-address 192.168.40.1 192.168.40.10
ip dhcp excluded-address 192.168.50.1
ip dhcp excluded-address 192.168.60.1
ip dhcp excluded-address 192.168.50.1 192.168.50.10
ip dhcp excluded-address 192.168.60.1 192.168.60.10
!
ip dhcp pool ITC
 network 192.168.10.0 255.255.255.0
 default-router 192.165.10.1
ip dhcp pool Manuf
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
ip dhcp pool billing
 network 192.168.30.0 255.255.255.0
 default-router 192.168.30.1
ip dhcp pool sales
 network 192.168.40.0 255.255.255.0
 default-router 192.168.40.1
ip dhcp pool HR
 network 192.168.50.0 255.255.255.0
 default-router 192.168.50.1
ip dhcp pool Management
 network 192.168.60.0 255.255.255.0
 default-router 192.168.60.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524KDLE-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.50.1 255.255.255.0
!
interface GigabitEthernet0/0.60
 encapsulation dot1Q 60
 ip address 192.168.60.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless

shanelab#
shanelab#

Switch Configuration

Switch#show run
Building configuration...

Current configuration : 1385 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 60
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end


Switch#