4/18 – Orca doesn't seem to read most of the screen elements on my system

I started Orca for the first time and it only seems to read the titles of windows and tabs or sometimes the first element in the window, but nothing else in the window.

When I go into the setup GUI (orca -s on the terminal) reads aloud what the mouse is in that particular window that belongs to orca itself, and it reads aloud things like window names on the application switcher.

But how do you let it read what is under the mouse position outside of your own setup GUI window? Would you suggest upgrading Orca or other components? Windows I tried: Terminal window, Google Chrome, the Atom editor.

My Orca version: 3.28.0

I actually use Orca to prove how well an application based on GTK's Accessibility Toolkit (ATK) or GTK's GNOME Accessbility Implementation Library can read Windows text. If you know of another project that is aimed at it, I would also be happy.

Audio – Bluetooth doesn't turn on my iPhone XR?

Got a very strange bug – I can't turn Bluetooth on or off. This is not at the device level – if you click Bluetooth in the settings, there is only a rotating death rule next to "Bluetooth". Bluetooth is switched off in the Control Center. When I tap it, it turns on, but the settings screen is still spinning. I also can't type it in the Control Center once I tap it.

Does anyone have a feel for whether it is a software or hardware problem? My bluetooth worked about an hour ago. I've seen a few articles that indicated that this was a hardware issue, but it appeared that these were mostly issues related to iPhone 5Cs. I've also seen some evidence that this is a software issue with an old version of iOS from 2017 that is obviously not relevant.

I've done all the obvious things like restarting the phone, performing a soft reset and even resetting all of my network settings.

I previously had AirPods Pro, an iPad, and Bose headphones in the saved pairings. All three were not connected. AirDrop also tells me that Bluetooth is disabled (even if it's enabled in the Control Center).

kde apps – KDE Marble doesn't show the legend

I am using Ubuntu Studio 20.04.

The geographic app KDE marble is a very powerful map viewer.

However, I've found a bug since I upgraded my system from 10/19 to 4/20 (but I'm not sure if this bug is directly related to the upgrade itself).

The bug affects the Legend panel: I can't see anything there.

I would expect to see all of the map symbols in this area, but … nothing is displayed.

What's going on here?

How could I get around this?

php7 – PHP doesn't load a specific extension if a relative path is given

I have a specific extension that does not load when I specify a relative path in it extension_dir Parameter. If I specify an absolute path, it will be loaded. I can't use an absolute path because I often have to move the location of the web server and it would be annoying to reconfigure all paths each time.

The only difference I notice is that this extension is one .win File and not a .dll.

PHP version is PHP 7.4.5 (cli) (built: Apr 14 2020 16:17:34) ( ZTS Visual C++ 2017 x64 )

Audio – How do I add a sound notification to an app that doesn't have one?

I'm using an app to copy and log video files that contain only a silent notification and I want to add a sound to the notification. My thought was that there might be a third party app like Keyboard Maestro that could trigger a sound action from notifying my app, but I don't think this is possible.

Can anyone suggest a solution or workaround?

Python – Understand why this buffer overflow attack doesn't work

I'm doing a buffer overflow challenge and can't understand exactly what I'm doing wrong. By debugging, I was able to figure out what my input should look like so that I can force the program to return to a function. From gdb I thought if I "aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaacdefbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb "I can get the program to return to cdef from 0x66656463. Here is a sc for all cases:
Enter the image description here
As you can see, the program managed to switch to 0x66656463. Now I have entered the address of the function via gdb and tried to place it with pwntools in place of cdef in little-endian order:

payload = "a" * 28 + "x56x85x04x08" + "b"*47
msg = "-1n" + payload

io.sendline(msg)

The reason for "-1 n" is that the program asks twice for input: When I first enter -1 and the second I try the exploit. So far I have only received a Segfault and the address I want to jump to should start a shell that I can use. I'm not sure what I'm doing wrong, and any help would be appreciated. If I had to guess that I was somehow wrong with the two inputs (they are read via fgets () in C if that is important)

Aperture priority on Nikon DF doesn't work with pre-AI lenses?

I just bought a 55 / 3.5 pre-AI.

To use aperture priority mode, I did the following:

  1. Raise the coupling lever on the meter
  2. Data on non-CPU lenses:
    Focal length: 55
    maximum appearance: F / 3.5
    Light meter coupling: non-AI

As I change the aperture, the display stays at F / 10. No wonder my photos are underexposed.
However, with other AI / AIS lenses, the camera correctly recognizes the lens hood. And of course the aperture priority works flawlessly.

Is there something wrong with my 55 / 3.5 pre-AI?