dpkg – Remove the desktop after upgrading to Ubuntu 19.10 and do not install xfce4

After installing xfce4 halfway, my network is disconnected and I try to install again, but I received the following error message:

W: Not using locking for read only lock file /var/lib/dpkg/lock-fronted
W: Not using locking for read only lock file /var/lib/dpkg/lock
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

After using the dpkg –configure -a I got this error:

dpkg: error: unable to access the dpkg database directory /var/lib/dpkg: Read-only file system

dpkg – pkg installation error

Crypt setup
Recommended packages:
keyutils
The following packages are updated:
Crypt setup
1 updated, 0 newly installed, 0 removed and 1507 not updated.
5 not fully installed or removed.
Requires 0 B / 208 kB archives.
After this process, 18.4 kB of storage space is released.
Do you want to continue? (Y / n) y
Pre-configure packages …
(Read database … 196550 files and directories currently installed.)
Preparation for unpacking … / cryptsetup_2% 3a2.2.2-3kali1_amd64.deb …
Unpack crypt setup (2: 2.2.2-3kali1) via (2: 2.0.2-1ubuntu1) …
dpkg: Error processing archive /var/cache/apt/archives/cryptsetup_2%3a2.2.2-3kali1_amd64.deb (–unpack):
try & # 39; / usr / sbin / luksformat & # 39; overwrite, which is also in the package cryptsetup-bin 2: 2.0.2-1ubuntu1
dpkg-deb: error: insert subprocess was terminated by signal (pipe broken)
Errors occurred during processing:
/var/cache/apt/archives/cryptsetup_2%3a2.2.2-3kali1_amd64.deb
E: The subprocess / usr / bin / dpkg returned an error code (1).
chinmay @ chinmay-Inspiron-15-3552: ~ $ clear

chinmay @ chinmay-Inspiron-15-3552: ~ $ sudo apt install clang
Read package lists … Done
Create dependency tree
Read status information … Done
You may want to & # 39; apt –fix -break install & # 39; to correct them.
The following packages have unfulfilled dependencies:
clang: Depends on: clang-9 (> = 9 ~), but it will not be installed
cryptsetup-initramfs: Depending on: cryptsetup (> = 2: 2.2.2-3kali1)
Breaks: Cryptsetup (< 2:2.0.3-1) cryptsetup-run : Depends: cryptsetup (>= 2: 2.1.0-6)
E: Unfulfilled dependencies. Try & # 39; apt –fix -break install & # 39; without packages (or provide a solution).
chinmay @ chinmay-Inspiron-15-3552: ~ $ apt –fix-defective installation
E: Lock file / var / lib / dpkg / lock – open could not be opened (13: authorization denied)
E: The administration directory (/ var / lib / dpkg /) cannot be locked. Are you root
chinmay @ chinmay-Inspiron-15-3552: ~ $ sudo -i
root @ chinmay-Inspiron-15-3552: ~ # apt –fix-defective installation
Read package lists … Done
Create dependency tree
Read status information … Done
Correct dependencies … Done
The following packages were installed automatically and are no longer required:
fonts-lato javascript-common john john-data libblas3 libgmp-dev
libgmpxx4ldbl libhttp-parser2.9 libjs-jquery liblinear4 libssh2-1 lua-lpeg
nasm nmap nmap-common postgresql python-chardet python-pkg-resources
Python-pygree ruby-at the same time ruby-did-you-mean-ruby-i18n ruby ​​mercenary
Ruby-Mini-Test Ruby-Net-Telnet Ruby-Power-Assert Ruby-Stringex Ruby test unit
ruby2.5-doc rubygems integration
Use & # 39; apt autoremove & # 39; to remove them.
The following additional packages are installed:
Crypt setup
Recommended packages:
keyutils
The following packages are updated:
Crypt setup
1 updated, 0 newly installed, 0 removed and 1507 not updated.
5 not fully installed or removed.
Requires 0 B / 208 kB archives.
After this process, 18.4 kB of storage space is released.
Do you want to continue? (Y / n) y
Pre-configure packages …
(Read database … 196550 files and directories currently installed.)
Preparation for unpacking … / cryptsetup_2% 3a2.2.2-3kali1_amd64.deb …
Unpack crypt setup (2: 2.2.2-3kali1) via (2: 2.0.2-1ubuntu1) …
dpkg: Error processing archive /var/cache/apt/archives/cryptsetup_2%3a2.2.2-3kali1_amd64.deb (–unpack):
try & # 39; / usr / sbin / luksformat & # 39; overwrite, which is also in the package cryptsetup-bin 2: 2.0.2-1ubuntu1
dpkg-deb: error: insert subprocess was terminated by signal (pipe broken)
Errors occurred during processing:
/var/cache/apt/archives/cryptsetup_2%3a2.2.2-3kali1_amd64.deb
E: The subprocess / usr / bin / dpkg returned an error code (1).
root @ chinmay-Inspiron-15-3552: ~ #

dpkg – Reconfigure root and postmaster mail recipients in Ubuntu

I have installed Exim and mailutils (for receiving) to send mail through PHP in Ubuntu. After installing it, I ran the command dpkg-reconfigure exim4-configI was asked to set the email recipient for root and postmaster (I was in a hurry). I typed root there (not sure if I made a typo). The next time I try to reconfigure Exim, I cannot set this one setting. How can I set this setting again? Please let me know. I can't find a solution myself.

apt – dpkg configure by util-linux never stops, no errors

I ran apt update a few days ago and it was never completed. I ctrl-c killed it and it said I had to dpkg --configure -a, I did it and tried to configure it util-linux, However, it never ends. I even let it run overnight for over 12 hours and it doesn't end there. There is also no error output. It just depends.

$ sudo dpkg --configure -a
Setting up util-linux (2.34-0.1ubuntu2.2) ...

I tried to do it with verbose debugging, but still no useful output to see.

$ sudo dpkg --configure -a -D42442
D000040: checking dependencies of util-linux:amd64 (- )
D000400:   checking group ...
D000400:     checking possibility  -> fdisk
D000400:       checking non-provided pkg fdisk:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> login
D000400:       checking non-provided pkg login:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libaudit1
D000400:       checking non-provided pkg libaudit1:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libblkid1
D000400:       checking non-provided pkg libblkid1:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libc6
D000400:       checking non-provided pkg libc6:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libcap-ng0
D000400:       checking non-provided pkg libcap-ng0:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libmount1
D000400:       checking non-provided pkg libmount1:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libpam0g
D000400:       checking non-provided pkg libpam0g:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libselinux1
D000400:       checking non-provided pkg libselinux1:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libsmartcols1
D000400:       checking non-provided pkg libsmartcols1:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libsystemd0
D000400:       checking non-provided pkg libsystemd0:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libtinfo6
D000400:       checking non-provided pkg libtinfo6:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libudev1
D000400:       checking non-provided pkg libudev1:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> libuuid1
D000400:       checking non-provided pkg libuuid1:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000400:   checking group ...
D000400:     checking possibility  -> zlib1g
D000400:       checking non-provided pkg zlib1g:amd64
D000400:       is installed, ok and found
D000400:     found 3
D000400:   found 3 matched 0 possfixbytrig -
D000040: ok 2 msgs >><<
D000040:     checking Breaks
D000400:       checking breaker login:amd64 virtbroken 
D000400:       checking breaker fdisk:amd64 virtbroken 
Setting up util-linux (2.34-0.1ubuntu2.2) ...
D000002: fork/exec /var/lib/dpkg/info/util-linux.postinst ( configure 2.34-0.1ubuntu2.1 )

It just sits and hangs there.

I can't run another apt Commands while the package is not configured and I don't want to restart without a properly, fully installed one util-linux Package.

I have no idea what to do. Any help is greatly appreciated.

Linux Docker | unknown environment `bash` | Subprocess / usr / bin / dpkg returned an error code (1)

My goal is to get a Docker container up and running with nordvpn installed and connected.

Get Docker Container going

sudo docker pull ubuntu:latest
sudo docker run -it ubuntu bash
// now im in the docker container
apt install update
apt install wget
wget {{nordvpn_link.deb}}
dpkg -i {{nordvpn_link.deb}}
// some errors about dependencies after above command so ...
apt install -f
// then
apt install nordvpn

First big mistake

root@f706a3f4012f:/home# apt install nordvpn
Reading package lists... Done
Building dependency tree       
Reading state information... Done
nordvpn is already the newest version (3.6.0-2).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? (Y/n) 
Setting up nordvpn (3.6.0-2) ...
(ERROR) Unknown environment `bash'
dpkg: error processing package nordvpn (--configure):
installed nordvpn package post-installation script subprocess returned error exit status 255
Errors were encountered while processing:
nordvpn
E: Sub-process /usr/bin/dpkg returned an error code (1)

I read here to run the following command

dpkg --configure -a
// errors
Setting up nordvpn (3.6.0-2) ...
(ERROR) Unknown environment `bash'
dpkg: error processing package nordvpn (--configure):
installed nordvpn package post-installation script subprocess returned error exit status 255
Errors were encountered while processing:
nordvpn

I'm not sure why this happens with the Docker container as the process went smoothly with my regular Ubuntu desktop installation.

linux error: dpkg returned an error code (1)

Ola, pessoal!

Gostaria de saber se poderiam me ajudar a resolver esse erro:

An installation program for LTS 18.04 was created, which contains the following information:

comando: sudo apt-get install software-properties-common

Read package lists … Done
Create the dependency tree
Reading status information … Done
The following packages were installed automatically and are no longer required:
amd64-microcode intel-microcode iucode-tool linux-headers-5.0.0-37
linux-image-generic-hwe-18.04 thermald
Please use "sudo apt autoremove" to remove them.
The following additional packages are installed:
Python3 software properties software properties GTK
The following packages are updated:
Python3 Software Properties Software Properties Common
Software Features-gtk
3 updated, 0 reinstalled, 0 removed and 2 not updated.
1 partially installed or removed.
It is necessary to include 96.3 kb in the archives.
After this process, 0 o additional storage space is used.
Do you want to continue? (We)
Received from: 1 http://fr.archive.ubuntu.com/ubuntu bionic-updates / main amd64 software-properties-common all 0.96.24.32.12 (10.0 kB)
Received from: 2 http://fr.archive.ubuntu.com/ubuntu bionic-updates / main amd64 software-properties-gtk all 0.96.24.32.12 (62.7 kB)
Received from: 3 http://fr.archive.ubuntu.com/ubuntu bionic-updates / main amd64 python3-software-properties all 0.96.24.32.12 (23.6 kB)
96.3 kb received in 0s (253 kb / s)
(Read database … 190376 files and directories already installed.)
Preparation for unpacking … / software-properties-common_0.96.24.32.12_all.deb …
Unzip software properties-common (0.96.24.32.12) to (0.96.24.32.11) …
Preparation for unpacking … / software-properties-gtk_0.96.24.32.12_all.deb …
Unpack software-properties-gtk (0.96.24.32.12) on (0.96.24.32.11) …
Preparation for unpacking … / python3-software-properties_0.96.24.32.12_all.deb …
Python3-software-properties (0.96.24.32.12) will be unpacked on (0.96.24.32.11) …
Configuration of linux-image-5.0.0-37-generic (5.0.0-37.40 ~ 18.04.1) …
Parameterization of python3 software properties (0.96.24.32.12) …
General configuration of the software properties (0.96.24.32.12) …
Configuration of software properties-gtk (0.96.24.32.12) …
Processing delayed actions ("triggers") for shared mime information (1.9-2) …
Editing delayed actions ("triggers") for Gnome menus (3.13.3-11ubuntu1.1) …
Processing delayed actions ("triggers") for dbus (1.12.2-1ubuntu1.1) …
Editing delayed actions ("triggers") for the Hicolor icon theme (0.17-2) …
Processing delayed actions ("triggers") to support MIME (3.60ubuntu1) …
Editing delayed actions ("triggers") for desktop file uses (0.23-1ubuntu3.18.04.2) …
Processing delayed actions ("triggers") for libglib2.0-0: amd64 (2.56.4-0ubuntu0.18.04.4) …
Processing delayed actions ("triggers") for man-db (2.8.3-2ubuntu0.1) …
Processing delayed actions ("triggers") for linux-image-5.0.0-37-generic (5.0.0-37.40 ~ 18.04.1) …
/etc/kernel/postinst.d/dkms:
* dkms: Run the automatic installation service for Kernel 5.0.0-37-generic
Error! The file dkms.conf could not be found.
The file does not exist.
…Fail!
run-parts: /etc/kernel/postinst.d/dkms ended with return code 4
dpkg: Error processing package linux-image-5.0.0-37-generic (–configure):
The subprocess of the installed Linux Image 5.0.0-37 generic package after installing the script returned error completion status 1
Errors occurred during execution:
Linux image-5.0.0-37-generic
E: Subprocess / usr / bin / dpkg returned an error code (1)

& # 39; & # 39; & # 39;

I'm hindering the installation of new software for my PC. O que devo fazer para solucionar o problema?

Obrigada desde yes!

dpkg – 18.04 "sudo apt autoremove" causes error "WARNING: missing / lib / modules / uname"

After updating the kernel to 5.0.0-36-generic, an error occurred while installing the updates after the kernel update. In particular, it appears to have manifested during the update of the "Linux Firmware" package.

When you run the software updater or "sudo apt update" in a terminal, all packages are kept up to date.

However, according to Synaptic Package Manager, the installation of the Linux firmware is still ongoing. When I try to reinstall it, I get an error similar to the one shown below.

I tried sudo apt clean and sudo apt to remove automatically. When I install packages using Synaptic, the installation reports errors, but the package is installed.

Computer boots OK.

The 18.04 installation runs on the second of three primary partitions / dev / sda2, Ubuntu 16.04 is on / dev / sda1 and / dev / sda3 is empty.

The error is as follows:

martin@computer:~$ sudo apt autoremove
(sudo) password for martin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up linux-firmware (1.173.12) ...
update-initramfs: Generating /boot/initrd.img-uname
WARNING: missing /lib/modules/uname
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: Bad version passed uname
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
depmod: ERROR: Bad version passed uname
update-initramfs: Generating /boot/initrd.img-uname-r
WARNING: missing /lib/modules/uname-r
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: Bad version passed uname-r
dpkg: warning: version 'uname-r' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname-r' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname-r' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname-r' has bad syntax: version number does not start with a digit
depmod: ERROR: Bad version passed uname-r
update-initramfs: Generating /boot/initrd.img-uname
WARNING: missing /lib/modules/uname
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: Bad version passed uname
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
dpkg: warning: version 'uname' has bad syntax: version number does not start with a digit
depmod: ERROR: Bad version passed uname
update-initramfs: Generating /boot/initrd.img--r
/usr/sbin/mkinitramfs: option requires an argument -- 'r'
W: non-GNU getopt
update-initramfs: failed for /boot/initrd.img--r with 1.
dpkg: error processing package linux-firmware (--configure):
installed linux-firmware package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
linux-firmware
E: Sub-process /usr/bin/dpkg returned an error code (1)
martin@computer:~$

There are currently three kernels in the 18.04 installation:

martin@computer:~$ ls -al /boot/
total 179196
drwxr-xr-x 3 root root 4096 Nov 15 22:48 .
drwxr-xr-x 24 root root 4096 Nov 14 20:48 ..
-rw-r--r-- 1 root root 217480 Nov 12 09:54 config-4.15.0-70-generic
-rw-r--r-- 1 root root 224516 Nov 11 08:44 config-5.0.0-35-generic
-rw-r--r-- 1 root root 224516 Nov 12 10:46 config-5.0.0-36-generic
drwxr-xr-x 6 root root 4096 Nov 13 20:50 grub
-rw-r--r-- 1 root root 39680508 Nov 13 19:29 initrd.img-4.15.0-70-generic
-rw-r--r-- 1 root root 41118914 Nov 13 17:33 initrd.img-5.0.0-35-generic
-rw-r--r-- 1 root root 41116325 Nov 15 16:23 initrd.img-5.0.0-36-generic
-rw-r--r-- 1 root root 10854263 Nov 15 22:48 initrd.img-uname
-rw-r--r-- 1 root root 10854268 Nov 15 22:48 initrd.img-uname-r
-rw-r--r-- 1 root root 182704 Jan 28 2016 memtest86+.bin
-rw-r--r-- 1 root root 184380 Jan 28 2016 memtest86+.elf
-rw-r--r-- 1 root root 184840 Jan 28 2016 memtest86+_multiboot.bin
-rw------- 1 root root 4066166 Nov 12 09:54 System.map-4.15.0-70-generic
-rw------- 1 root root 4301791 Nov 11 08:44 System.map-5.0.0-35-generic
-rw------- 1 root root 4301791 Nov 12 10:46 System.map-5.0.0-36-generic
-rw------- 1 root root 8363672 Nov 12 09:58 vmlinuz-4.15.0-70-generic
-rw------- 1 root root 8785656 Nov 11 08:48 vmlinuz-5.0.0-35-generic
-rw------- 1 root root 8785656 Nov 12 10:47 vmlinuz-5.0.0-36-generic
martin@computer:~$

dpkg does not work with the installation of termux ubuntu, returns tar errors and terminates the program with the error code 1

I tried installing Termux Ubuntu on ChromeOS without developer mode or root privileges, and was successful until then. I accessed an Ubuntu shell from termux, but dpkg returns this error for each package, rendering the system unusable. This is the output of "apt install nano"

root @ localhost: ~ # apt install nano

Read package lists … Done

Create dependency tree

Status information is read … Done

Suggested packages:

spell

The following NEW packages will be installed:

Nano

0 updated, 1 reinstalled, 0 removed and 0 not updated.

Requires 243 kB archives.

After this process, 823 KB of additional space will be used.

Get: 1 http://archive.ubuntu.com/ubuntu bionic / main i386 nano i386 2.9.3-2 (243 kB)

Retrieved 243 kB in 1s (198 kB / s)

debconf: Delay package configuration because apt-utils is not installed

E: setting in start via TCSAFLUSH for stdin failed! – tcsetattr (13: permission denied)

dpkg-deb: unrecoverable fatal error, crash:

Waiting for tar subprocess failed: unknown error 512

dpkg: Error while processing the archive /var/cache/apt/archives/nano_2.9.3-2_i386.deb (–unpack):

dpkg-deb –control subprocess returned error completion status 2

There were errors during processing:

/var/cache/apt/archives/nano_2.9.3-2_i386.deb

tar:.: Can not mkdir: No such file or directory

tar: ./conffiles: Can not open: No such file or directory

tar: ./control: Can not open: No such file or directory

tar: ./md5sums: Can not open: No such file or directory

tar: ./postinst: Can not open: No such file or directory

tar: ./prerm: Can not open: No such file or directory

tar: Stop with error status due to previous error

E: subprocess / usr / bin / dpkg returned an error code (1)

debian – kali linux v. 5.3.0 dpkg and postgresql are not updated

This is the error I keep getting when trying to update:

package configuration

┌────────────────────────────────────────────────────────────────────────────────────────────────── ┐
│ │
│ Outdated major version 11

Post PostgreSQL version 11 is outdated, but the server or client packages
│ are still installed. Please install the latest packages (postgresql-12
│ and postgresql-client-12) and update the existing clusters with
│ pg_upgradecluster (see man page).

│ Please note that the installation of postgresql-12 is done
│ Automatically create a default cluster 12 / main. If you want to upgrade
│ In the 11 / main cluster, you must remove the already existing 12 cluster
│ (pg_dropcluster –stop 12 main, details see man page).

│ The old server and client packages are no longer supported. After this
│ Existing clusters are updated, the postgresql-11 and
│ postgresql-client-11 packages should be removed.

│ For more information, see /usr/share/doc/postgresql-common/README.Debian.gz

I was trying to install, uninstall, update, pg_dropcluster, I'm not sure what else to do.