mongodb – Notification for host failure and health status

I set up a mongodb cluster with replica sets for high availability. My configuration seems to work well, as the database can operate even if I turn off some of my hosts.

My question is: How can I find out that a host failed or get the health status of the cluster? I wish to have something like a dashboard or a “health status”. My current solution is to connect to the cluster and query the replication state once in a while.

Can anybody recommend a tool which reports failover per email or provides a kind of dashboard where I can see the cluster health?

I already searched for solutions and found solutions like this:
Percona Monitoring and Management but it considers performance metrics rather than failover related information.

Thank you for your help.

postfix – Virtual Server and gmail 550-5.7.26 authentification failure

I’m running ubuntu 18.04 with postfix as a virtual machine at my home. I would like to send a several emails per day to my account at gmail.

In the mail log I’m getting following message:

 Nov  6 07:00:50 zipbub postfix/smtp(6768): 4E9291017DB: to=<myemail@gmail.com>, relay=gmail-smtp-in.l.google.com(173.194.73.26):25, delay=1.8, delays=0.12/0.21/0.88/0.56, dsn=5.7.26, status=bounced (host gmail-smtp-in.l.google.com(173.194.73.26) said: 550-5.7.26 This message does not have authentication information or fails to 550-5.7.26 pass authentication checks. To best protect our users from spam, the 550-5.7.26 message has been blocked. Please visit 550-5.7.26  https://support.google.com/mail/answer/81126#authentication for more 550 5.7.26 information. q19si232367lji.214 - gsmtp (in reply to end of DATA command))

Server should represent itself as zipbub.mydomain.com.

cat /etc/mailname
zipbub.mydomain.com

Domain is pointing back to my home IP address (which is static).
Reverse DNS lookup does not resolve back my IP address to zipbub.mydomain.com. It does not resolve to any DNS name at all.
I’m not sure whether it is possible to assign reverse DNS correctly and how/who can do this.

zipbub.mydomain.com hold following TXT record:

v=spf1 a mx -all

dkim is not enabled. Postfix TLS is enabled.

postconf -n

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
compatibility_level = 2
inet_interfaces = all
inet_protocols = all
mailbox_size_limit = 0
mydestination = $myhostname, zipbub.mydomain.com, localhost.mydomain.com, , localhost
myhostname = zipbub.mydomain.com
mynetworks = 127.0.0.0/8 (::ffff:127.0.0.0)/104 (::1)/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost =
smtp_tls_mandatory_ciphers = high
smtp_tls_mandatory_protocols = !SSLv2,!SSLv3
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_mandatory_ciphers = high
smtpd_tls_mandatory_protocols = !SSLv2,!SSLv3
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
tls_high_cipherlist = ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!3DES:!MD5:!PSK

What options do I have?

windows 10 – Failure to recognize cpu’s virtualization capability

I have already activated VT-d in the BIOS and I have already activated the Hyper-V features, but in the System Information, he says that virtualization is not supported.

system infos

I use Windows 10 Pro and my processor is Core I5 ​​6500, on the intel website it says it has support for VT-x virtualization technology.

This is a prerequisite of the docker for windows.

I don’t know what else to do and I need to configure the docker. 🙁

bash – Backup Script Failure After Upgrade to Ubuntu 20.04.1

For years I’ve backed up my system to an external hard drive using a shell script with a simple copy command like

cp -uvR Documents/* “/media/myUserName/MyBackupDevice/Documents/”

After upgrading from Ubuntu 18 to Ubuntu 20.04.1, my script will only update files that already exist on the backup device. Where the destination file does not yet exist, no file is created and the copy fails with a message like:

cp: cannot create regular file ‘/media/myUserName/MyBackupDevice/Documents/Rest/of/Path/FileName.pdf’: Invalid argument

Depending on which files I’ve modified, sometimes a directory to which the script could not write a new file is the same directory in which it could update a pre-existing file.

Any suggestions on how to adapt my script?

linux – MSSQL, Ubuntu server – failure: remote connection from Win 7

Our analytical lab (chemistry) has an information management system (LIMS) that uses an MSSQL database. Technicians interact with the system through a Windows form application that is closed-source and permits only SQLOLEDB.1, MSOLEDBSQL, and SQLNCLI11.1 (Native Client 11) connections (choices are picked from a dropdown box at login). Our production server is MSSQL 2016 running on Windows Server 2012.

The lab has several analytical instruments that are constrained to Win 7 and Win XP for data acquisition. This is an immutable constraint.

On the production setup, all machines make a connection with legacy SQLOLEDB.1 but Win 10 Machines can alternatively connect with MSOLEDBSQL, and SQLNCLI11.1 as well. Win 7 and XP machines cannot.

I am prototyping an MSSQL Server 2019 upgrade on a Ubuntu server. As configured, no machines can connect to it using the legacy SQLOLEDB.1 connection. The LIMS application is able to connect to it from Win 10 using either MSOLEDBSQL or SQLNCLI11.1. The Win 7 and XP machines cannot connect with any of the protocols.

If this is to work, I have two choices:

  1. Somehow configure MSSQL on the Ubuntu server to accept SQLOLEDB.1 connections.
  2. Somehow configure XP and Win 7 machines to make MSOLEDBSQL or SQLNCLI11.1 connections.

I cannot figure out how to do either one. Please help.

8 – Failure in “file module Update #8700”

file module

Update #8700
•Failed: DrupalCoreFieldFieldException: Field storage definition for 'type' could not be found. in DrupalCoreEntitySqlSqlContentEntityStorageSchema->getEntitySchema() (line 979 of /var/www/xxxxxxx.com/core/lib/Drupal/Core/Entity/Sql/SqlContentEntityStorageSchema.php).

This message is shown after running update.php

I believe this is also related to a brand new problem we’re having since the upgrade to 8.9.7 — we can no longer add images.

Need advice for how to perform this update. At this point I just want it done, so even if I have to manually hack something I’m fine with that. I can revisit how to fix things properly once the site is working again.

JOURNEY – My Journey Success Or Failure | Proxies-free

Hi, there, congrats with your Coinpot Journey.
I was about to make the same journal for my Coinpot account, but since we already have yours I think it will interesting to follow your journey.

I am about to reach VIP Silver account today, and aiming for higher level. Hopefully you also allow us to contribute in this thread while accompany you with your interesting story.

Good Luck with your endeavour.

crash – OPenstack cinder failure

We using openstack rocky, and it was working fine til we adding some compute nodes and ceph(s).
Now we have some issue with cinder stability.
Cinder is crashing during rally test or even more, when rally test is done or not executed.
We searched in log files and no sign of error or failure message.
Any idea for this trouble ?
Thanks.