mac appstore – Why aren’t apps like Gradle, Carbon Copy Cloner, Android Studio, etc. in the App Store? How to “safely” install them?

To keep things simple, I’d like to only install apps from the official AppStore. But, I’m frequently finding that the apps that I need are not on the AppStore such as Gradle, Carbon Copy Cloner, and Android Studio. It is what it is, and I install them, but what’s the deal?

Why aren’t some legitimate MacOS apps in the AppStore?
What do expert Mac users do when they need apps outside the AppStore?
Is the only solution to use checksums to validate that the downloaded files are the correct files?

iso image – Is it recommended to put a custom Windows install or keep the brand’s one?

Heelo everyone,

I’ve read some thread about that, but I’m still not get a real answer.
I just got an Acer with an I7 8xxx, and a good SSD. The PC is quick, but if it can be better, that better! I’m making customs windows 10 iso with WinToolsKit to light it up, and remove all the unnecessary package to run on low config PC. I hesitate to make one for this PC, but I don’t know if I can get issues with hardware like the battery or just a bad windows build. I’m using it for study and programming.

For you, with your experience, do you recommend me to put a custom W10 iso on it?
And do you are in “let it on battery when you can” or “cable power it at soon as you can” ? (to save the battery life).

Thanks for your time.

How to try to install iOS-14 on an iPhone-6?

I use an iPhone-6 (16-GB) and am up to date with iOS-12.4.8 (because iOS-13 does not support iPhone-6).

Does the App Store just identify my phone as iPhone-6 via a physical identifier in the phone, and that prevents me from downloading any iOS version beyond 12.4.8? How might I get around this?

Maybe the drivers for the camera and fingerprint reader in the iPhone-6 are not in iOS-13? But, I might be ok without both of those. Losing gps, wifi, or bluetooth would not be ok. So, I’d like to just give iOS-14 on an iPhone-6 a look and learn something by doing this. But, I’ll probably buy a new phone.

rooting – Can i mount a Veracrypt container as a regular sd and install apks inside?

I work fine with the Linux terminal, but I am taking my first steps on Android, so I apologize if I ask something too obvious for someone with some knowledge on the subject.

I am going to acquire a Nexus 5 and I would like to be able to openly modify it to do what I need:

My idea is to encrypt the whole device (I think I need android 5.0+ for this. Is this correct?).

Besides, I have a container encrypted with Veracrypt on an SD card. I would like to be able to decrypt said container with EDS and mount said container as a separate volume (if the main sd is mounted on /mnt/storage01, I would like to mount the decrypted volume on /mnt/storage02, for example) to later install ALL the apps I need in the container. So that none of the applications work nor can they write data that is container of Veracrypt until said container is unencrypted and mounted.

This is possible being root?

Is there some type of terminal that allows me to control all the “imaginable” aspects of my phone similar to the flexibility that exists in Linux, for example, with bash?

I have read about ADB but I think it is more focused on managing files, permissions and some specific desktop <-> mobile commands rather than on a persé terminal. This is correct?

Thanks for the help. I will appreciate any indication in the right direction.

boot – Please, please help me install Ubuntu as a UEFI

I have been working at this for easily 15 hours now and nothing works. First I had linux installed and I wanted to install windows as a dual boot, which took 8 hours because of all the issues. It finally worked but I had windows as UEFI and Linux as Legacy. So I followed multiple websites on how to convert linux to UEFI and nothing worked so I thought, hey maybe I’ll reformat all the drives that I have Linux on and just do a fresh restart. Well in order to create a UEFI boot loader I have to switch legacy mode off in my bios. However anytime I try to run my USB drive with Ubuntu loaded in UEFI mode, I get multiple errors saying,

ACPI BIOS error (bug) Faliure creating named object(_SB.PCI0.XC.RHUB.8809._UPC), AE_ALREADY_EXISTS, During name lookup/catalog (2019086/psob.ject-220)

Over and over again along with weird colored lines streaking all across the black background and it just sits there. I tried loading it up many times, I made multiple ISO. files on multiple flash drives with different tools and trying GPT, FAT32 etc and nothing works. Now I have no linux and a slow working windows 10 on my HDD and my SSD is empty waiting for linux to get reinstalled. Please help! I don’t care what I have to delete I just want this working. Thank you!

hplip-gui failing to install properly after not cleanly removing old hplip install

I am running Ubuntu 20.04 on a Lenovo Yoga 13. I had some version of HPLIP installed (possibly from the installer script on hplip website) and went to setup a wireless printer but it failed with

warning: /usr/share/hplip/plugin.spec file doesn't exists.
error:  Printer queue setup failed.   Error : successful-ok-ignored-or-substituted-attributes

I ran an hp-check and it complained about not having python-qt4 but I checked around the web and found that the hplip from the Ubuntu 20.04 sources is compiled against qt5 so I thought running

sudo apt install hplip

would fix the problem, but it did not. I have no tried several rounds of

apt purge hplip hplip-gui printer-driver-hpcups
apt install hp-gui

but now it seems even more broken. I am no getting

warning: ubuntu-20.04 version is not supported. Using ubuntu-19.10 versions dependencies to verify and install...


error: HPLIP not found.

when I run hp-check

How can I cleanly install hplip-gui from where I am?

rom flashing – Can I install a ROM made for a different device?

Short answer:

You can only install ROMs compatible with your device

Longer version

Different Android devices use different hardware, which requires special drivers (e.g. the camera). Those drivers are sometimes/often proprietary (take e.g. Sony, which almost made it into the AOSP project — but had difficulties due to those proprietary parts and thus had to back-out again: AOSP only allows for non-proprietary, Open Source code, like its name suggests: Android Open Source Project). Installing an incompatible ROM, in the best case, makes components of your device unavailable (they are simply not working). In the worst case, you might “brick” it (it won’t even start up).

You might want to check the question Where can I find stock or custom ROMs for my Android device? to find ROMs compatible with your device. Most times, there are several choices available to meet the user’s requirements: Less “bloatware” but more performance, more fancy stuff, custom enhancements… So you still can make your pick.

Other recommended readings on this topic:

storage – Dual boot (windows/Ubuntu 20.04) new drive install problem

So I have 2 drives in my system. One running Windows 10 and one running Ubuntu 20.04. I have no problems with dual boot. My windows drive has been running out of space so I got a new hdd to install in my system. I installed it and in windows it does not appear anywhere (so i can’t use it ) but it does appear in Ubuntu, but I don’t want to use it there. I tried pulling out the Ubuntu drive BCS I thought maybe without that I would be able to boot into windows and have the new drive appear but all I got was an error message after the post screen. What should I do ?

installation – All I Want To Do Is Install Magento2 and all I get are problems!!!!! It’s driving me mad!

honestly I’ve been driven mad by various online guides on how to install Magento2 on CentOS only to find there’s some certain version of PHP I need, or finding out that the web installer does not work – or even the CLI installer won’t work. After spending days trying to figure it all out, then dealing with Magento2 errors like permissions, missing files, etc I got it to work.

So, I’ve put up my own A,B,C guide for anyone who is struggling to get Magento2 to install and work, especially on CentOS.

I really hope it helps – because believe me, there’s nothing worse that an “install guide” that just doesn’t work!!

Let’s get started then!

So first off, you’ll need Magento2 downloaded. I’m using Magento CE 2.4.0 (2020-07-24-11-08-21):
If the zip file you download from Magento is different then,
Just do a Google/Bing search for:

If you can’t find it, it’s here:

Next you’ll need CentOS 7.0. I’m using Magento CentOS 7 (Minimal 2003):
If the zip file you download from CentOS is different then,
Just do a Google/Bing search for:

If you can’t find it, it’s here:

A. Install And Configure CentOS 7 for Magento 2.4.0

Right, we’ll need to update CentOS and install Magento2 required files
please note, these can be version specific – but this guide ensures the versions are 100% correct.