Can’t install wine on ubuntu 20.04

I recently installed ubuntu 20.04.2 LTS and I want to install wine. I did sudo dpkg –add-architecture i386, then sudo apt update. When I ran sudo apt install wine, it gave me this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  apache2-data apache2-utils firebird3.0-common firebird3.0-common-doc
  fonts-lyx fprintd libapr1 libaprutil1 libaprutil1-ldap libbson-1.0-0
  libcapstone4 libdbi-perl libdmapsharing-3.0-2 libdouble-conversion3
  libfbclient2 libfmt7 libfprint-2-2 libgpod-common libgpod4
  libgtksourceview-3.0-1 libgtksourceview-3.0-common
  libgtksourceviewmm-3.0-0v5 libhtml-linkextractor-perl libice-dev
  libimagequant0 libio-socket-socks-perl liblirc-client0
  liblwp-protocol-socks-perl libmd4c0 libmemcached11 libmessaging-menu0
  libmongoc-1.0-0 libmongocrypt0 libopts25 libpam-fprintd libpcre2-16-0 libpq5
  libpthread-stubs0-dev libpulsedsp libqt5core5a libqt5dbus5 libqt5network5
  libqt5positioning5 libqt5qml5 libqt5qmlmodels5 libqt5sensors5
  libqt5webchannel5 libqt5xml5 libqt5xmlpatterns5 libsbc1 libserf-1-1
  libsgutils2-2 libsm-dev libspeexdsp1 libtommath1 libunbound8 libutf8proc2
  libwebrtc-audio-processing1 libxdmcp-dev libxml++2.6-2v5 libxvmc1
  libxxf86dga1 python3-argcomplete python3-cffi python3-geoip python3-geoip2
  python3-maxminddb python3-olefile python3-ply python3-pycparser
  python3-pygeoip qttranslations5-l10n x11-apps x11-session-utils x11proto-dev
  xinit xorg-sgml-doctools xtrans-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  fonts-wine i965-va-driver intel-media-va-driver libaom0 libavcodec58
  libavutil56 libcapi20-3 libcodec2-0.9 libfaudio0 libgsm1 libigdgmm11
  libodbc1 libopenal-data libopenal1 libsdl2-2.0-0 libshine3 libsndio7.0
  libstb0 libswresample3 libva-drm2 libva-x11-2 libva2 libvkd3d1 libwine
  libx264-155 libx265-179 libxvidcore4 libzvbi-common libzvbi0 wine64
Suggested packages:
  i965-va-driver-shaders libmyodbc odbc-postgresql tdsodbc unixodbc-bin sndiod
  gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly
  ttf-mscorefonts-installer q4wine winbind winetricks playonlinux wine-binfmt
  dosbox exe-thumbnailer | kio-extras wine64-preloader
Recommended packages:
  libosmesa6 wine32
The following packages will be REMOVED:
  apache2 apache2-bin brutespray cherrytree cutycapt dradis edb-debugger
  edb-debugger-plugins firefox gdm3 gir1.2-gst-plugins-base-1.0 gir1.2-rb-3.0
  gnutls-bin gstreamer1.0-gl gstreamer1.0-gtk3 hydra libaprutil1-dbd-sqlite3
  libatk-wrapper-java libatk-wrapper-java-jni libcanberra-pulse
  libdbd-sqlite3-perl libgnutls-dane0 libqt5gui5 libqt5printsupport5
  libqt5quick5 libqt5svg5 libqt5webkit5 libqt5widgets5 libsvn1 libx11-dev
  libxau-dev libxcb-icccm4 libxcb-image0 libxcb-keysyms1 libxcb-render-util0
  libxcb-shape0 libxcb-xinerama0 libxcb-xinput0 libxcb-xv0 libxcb1-dev
  libxt-dev medusa mesa-vulkan-drivers pulseaudio pulseaudio-module-bluetooth
  pulseaudio-utils python3-cairocffi python3-pil python3-xcffib
  qt5-gtk-platformtheme rhythmbox-plugins sqlite3 sqlsus teams thunderbird
  thunderbird-gnome-support thunderbird-locale-en thunderbird-locale-en-us
  ubuntu-desktop ubuntu-desktop-minimal x11-utils xorg xserver-xephyr
  xserver-xorg-video-intel xsser
The following NEW packages will be installed:
  fonts-wine i965-va-driver intel-media-va-driver libaom0 libavcodec58
  libavutil56 libcapi20-3 libcodec2-0.9 libfaudio0 libgsm1 libigdgmm11
  libodbc1 libopenal-data libopenal1 libsdl2-2.0-0 libshine3 libsndio7.0
  libstb0 libswresample3 libva-drm2 libva-x11-2 libva2 libvkd3d1 libwine
  libx264-155 libx265-179 libxvidcore4 libzvbi-common libzvbi0 wine wine64
0 upgraded, 31 newly installed, 65 to remove and 0 not upgraded.
Need to get 46,3 MB of archives.
After this operation, 1.162 MB disk space will be freed.
Do you want to continue? [Y/n] 

If I run this command, it will break by whole system, how do I install wine without breaking everything?

Can I backup my phone or install TWRP recovery while stuck in Lineage OS recovery?

Highly unfortunately for me, I had thought it was a great idea not to make any backups when going to test if I was properly able to upgrade/downgrade Lineage OS versions. I had replaced my TWRP recovery with Lineage OS’s recovery, and then I “upgraded” to the same Lineage OS version I had currently been running, and my phone ran into a boot loop (The never-ending Lineage OS bootup screen). I believe I ran into this boot loop because I might have previously accidentally installed TWRP’s “system” app, and this would have been a problem due to LineageOS’s enforcement of priv-app whitelisting rules.

My device is a: LG H830

What I do have: Root, an unlocked bootloader, ADB/Fastboot, the TWRP recovery file

I believe I am screwed and that there’s no way out of this except just factory resetting/formatting everything. If I was correct in my research, my phone model blocks all fastboot commands, excluding bootloader + “unlock” related commands, and as a result, I don’t believe I am able to do a backup using ADB (I tried adb backup -all and it didn’t work). Lineage OS recovery has no way of backing up files, and I don’t believe it is possible to use it to flash TWRP recovery. All I need to be able to do is to save/backup my photos (Which are located in my internal storage). I think it is highly probable that I have finally entered into a hole that I can’t get out of. However, if anyone has any ideas about what I could do to either back up what’s on my phone (Mainly photos/internal storage if possible) or to flash TWRP without resetting/formatting everything, it would be substantially appreciated. Thank you!

Sources I checked out:

Team Win Recovery Project for the LG G5 – Post indicates that LG G5 H830 has flashing locked

Backup & Restore Android with ADB – Backing up via ADB would have worked if I was able to successfully boot into Lineage OS and approve the backup operation, but I can’t because I am limited to being able to boot in everything except system

Does Lineage Recovery have backup? – This is a post with answer(s) that designate the fact that Lineage OS’s recovery isn’t able to backup

windows – How to install SBS2K w/out SBS4/4.5?

I am trying to install Microsoft Small Business Server 2000 on a VM. I have been able to run the setup, except for this one unskippable section whare you have to verify your installation using Disc 1 of either Small Business Server 4.0 or 4.5. I can’t find an archive of SBS 4 anywhere, and I can’t continue without doing this step. Can someone find an archive of the discs for me, or at least tell me how to bypass this check?

magento2.3 – Composer can’t install any module due to “Your requirements could not be resolved to an installable set of packages”

Running 2.3.6
When I try to install any module via composer I get the following error:

 ()$ COMPOSER_MEMORY_LIMIT=-1 composer require stripe/stripe-php:^7
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
./composer.json has been updated
Loading composer repositories with package information
Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove magento/product-community-edition 2.3.6
    - Conclusion: don't install magento/product-community-edition 2.3.6
    - Installation request for magento/product-community-edition 2.3.6 -> satisfiable by magento/product-community-edition(2.3.6).
    - Installation request for veriteworks/cookiefix ^3.0 -> satisfiable by veriteworks/cookiefix(3.0.0).
    - Conclusion: don't install magento/framework 102.0.6-p1
    - magento/product-community-edition 2.3.6 requires laminas/laminas-code ~3.3.0 -> satisfiable by laminas/laminas-code(3.3.2, 3.3.0, 3.3.1).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.0).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.1).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.2).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.2).
    - Can only install one of: laminas/laminas-code(3.4.1, 3.3.2).
    - Conclusion: install magento/framework 102.0.6-p1|install laminas/laminas-code 3.4.1


Installation failed, reverting ./composer.json to its original content.

What is composer telling me to do?

Is it possible i made a mess since few days ago (before that I think
everything was working fine) and then I launched “composer
dump-autoload -o” for some reason?

Edit:
i ran same command and got different error

     composer require stripe/stripe-php:^7
The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "laminas/laminas-dependency-plugin" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/composer-root-update-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
./composer.json has been updated
The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "laminas/laminas-dependency-plugin" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/composer-root-update-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Running composer update stripe/stripe-php
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - magento/composer-root-update-plugin is locked to version 1.0.0 and an update of this package was not requested.
    - magento/composer-root-update-plugin 1.0.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api(2.0.0) but it does not match the constraint.
  Problem 2
    - Root composer.json requires veriteworks/cookiefix ^3.0 -> satisfiable by veriteworks/cookiefix(3.0.0).
    - veriteworks/cookiefix 3.0.0 requires magento/framework ~102.0.6-p1||~103.0.1 -> found magento/framework(102.0.6-p1, 103.0.1, 103.0.1-p1, 103.0.2) but the package is fixed to 102.0.6 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
  Problem 3
    - dealerdirect/phpcodesniffer-composer-installer is locked to version v0.5.0 and an update of this package was not requested.
    - dealerdirect/phpcodesniffer-composer-installer v0.5.0 requires composer-plugin-api ^1.0 -> found composer-plugin-api(2.0.0) but it does not match the constraint.
  Problem 4
    - laminas/laminas-dependency-plugin 1.0.4 requires composer-plugin-api ^1.1 -> found composer-plugin-api(2.0.0) but it does not match the constraint.
    - magento/product-community-edition 2.3.6 requires laminas/laminas-dependency-plugin ^1.0 -> satisfiable by laminas/laminas-dependency-plugin(1.0.4).
    - magento/product-community-edition is locked to version 2.3.6 and an update of this package was not requested.

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

I will install Elementor Pro Astra Agency on your WordPress website for $5

I will install Elementor Pro Astra Agency on your WordPress website

Hi, Are you looking for Astra Pro, Astra Agency Bundle, and Elelemtor Pro? Here I am …

I will install and activate Astra Pro, Astra Agency Bundle, and Elementor Pro with my official license where you will get lifetime updates.

Elementor Pro comes with 1 year of free updates but don’t worry, I renew my license every year so that my clients don’t suffer from updates.

What I am Offering in this Service:

· Astra Pro Plugin

· Premium Starter Templates

· Convert Pro

· Schema Pro

· WP Portfolio

· Ultimate Addon for Elementor

· Ultimate Addon for Beaver Builder

· Elementor Pro

· WProcket

· Smush Pro

· WPML

Note: All files are 100% Original and virus-free. I’ll only install these on your WordPress website. I won’t provide files or API Key info.


Why me?
Fast Delivery

Unlimited Revisions

100% Original Products

So what are you looking for? Just place the order!!

.

partitioning – Removing the Zorin-vg mount point to erase disk and install another OS?

I’m very new to linux and have installed Zorin OS, which I think is based on Ubuntu, as the only OS on my machine and I want to remove it but can’t get past the partition stage. It appears that the disk is now called /dev/zorin-vg.

I read that sudo swapoff -a might help but it has not.

Is there something that must be done in Ubuntu-based linux distributions to “free-up” the disk to be erased?

I’m trying to use Calamare to partition automatically at install of new OS but it shows only the option to manually set a partition. It also listw two disks in the drop-down. One is the system name that one would expect to find there and the other is zorin-vg.

If choose the first, the only option is to manually partition. If choose zorin-vg, then all the options appear but the install fails in about five seconds at the mount stage.

How can I get it such that a new OS can be installed replacing Zorin?

Thank you.