Magento 1 and Google Cloud Platform SQL: Mysqlserver has disappeared

I would like to know if anyone has any experience with the Google Cloud SQL platform.

We are experimenting with a very annoying problem that is difficult to fix.

A "MySQL server is gone" happens to appear.

Our architecture uses computer engines connected to a Google Cloud SQL database.

We don't have as many options to customize my.cnf as it is a managed service.

Here is a copy of the show variables: https://pastebin.com/Xaswtt72

I will add an example of an incident and the corresponding screenshot in New Relic

Screenshot new relic

Screenshot New Relic2

As you can see, the connection lasts forever. While I checked in the Cloud SQL platform logs, neither the CPU (less than 10%) nor RAM / network / I / O was loaded

We know that our code can certainly be highly optimized, but we still don't understand why we are experimenting with such an oversized architecture (10 front servers, database with 8 VCPU and 30 GB RAM and 500 GB SSD storage) Kind of problems, especially when our website is not loaded as much (less than 60 RPM average).

Google support can't find anything. If any of you had any trace, it would be of great help already.

Thank you in advance!

The .PID file is deleted when mysql.server start is executed

I have MySQL installed Brew install MySQL and when I run mysql.server start, I get the error ERROR! The server was stopped without updating the PID file (/usr/local/var/mysql/User-Macbook-Pro.local.pid).
After creating the PID file, I start mysql.server start and get the same error. I tried to delete the .err file, but it constantly removes my .pid file. Any ideas, what am I doing wrong?

Software Installation – dpkg: error handling package mysql-server (–configure): dependency issues – remain unconfigured

I get the following errors when I install mysql-sever.

lubuntu @ lubuntu: ~ $ Sudo apt install mysql server
Read package lists ... Done
Create dependency tree
Status information is read ... Done
The following additional packages will be installed:
libaio1 libcgi-fast-perl libcgi-pm-perl libevent-core-2.1-6 libfcgi-perl
libhtml-template-perl mysql-client-5.7 mysql-client-core-5.7
mysql-server-5.7 mysql-server-core-5.7
Suggested packages:
libipc-sharedcache-perl mailx tinyca
The following NEW packages will be installed:
libaio1 libcgi-fast-perl libcgi-pm-perl libevent-core-2.1-6 libfcgi-perl
libhtml-template-perl mysql-client-5.7 mysql-client-core-5.7 mysql-server
mysql-server-5.7 mysql-server-core-5.7
0 updated, 11 reinstalled, 0 removed and 138 not updated.
You need 20.8 MB of archives.
After this process, 160 MB of additional storage space is needed.
Would you like to continue? [Y/n] y
Get: 1 http://archive.ubuntu.com/ubuntucosmic/main amd64 libaio1 amd64 0.3.111-1 [7224 B]
Get: 2 http://security.ubuntu.com/ubuntu cosmic-security / main amd64 mysql-client-core-5.7 amd64 5.7.24-0ubuntu0.18.10.1 [7034 kB]
Get: 3 http://archive.ubuntu.com/ubuntucosmic/main amd64 libevent-core-2.1-6 amd64 2.1.8-stable-4build1 [85.9 kB]
Get: 4 http://archive.ubuntu.com/ubuntucosmic/main amd64 libcgi-pm-perl every 4.40-1 [186 kB]
Get 5 http://archive.ubuntu.com/ubuntucosmic/main amd64 libfcgi-perl amd64 0.78-2build1 [32.8 kB]
Get: 6 http://archive.ubuntu.com/ubuntucosmic/main amd64 libcgi-fast-perl all 1: 2.13-1 [9940 B]
Get: 7 http://archive.ubuntu.com/ubuntucosmic/main amd64 libhtml-template-perl every 2.97-1 [59.0 kB]
Get: 8 http://security.ubuntu.com/ubuntu cosmic-security / main amd64 mysql-client-5.7 amd64 5.7.24-0ubuntu0.18.10.1 [2302 kB]
Get: 9 http://security.ubuntu.com/ubuntu cosmic-security / main amd64 mysql-server-core-5.7 amd64 5.7.24-0ubuntu0.18.10.1 [7835 kB]
Get: 10 http://security.ubuntu.com/ubuntu cosmic-security / main amd64 mysql-server-5.7 amd64 5.7.24-0ubuntu0.18.10.1 [3238 kB]
Get: 11 http://security.ubuntu.com/ubuntu cosmic-security / main amd64 mysql-server all 5.7.24-0ubuntu0.18.10.1 [9956 B]
20.8 MB in 8 seconds (2598 kB / s)
Preconfigure packages ...
Select the previously unselected package libaio1: amd64.
(Reading the database ... 243259 files and directories currently installed.)
Preparation for unpacking ... / 00-libaio1_0.3.111-1_amd64.deb ...
Unpack Libaio1: amd64 (0.3.111-1) ...
Select the previously unselected mysql-client-core-5.7 package.
Preparation for unpacking ... / 01-mysql-client-core-5.7_5.7.24-0ubuntu0.18.10.1_amd64.deb ...
Unpack Mysql-client-core-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Select the previously unselected mysql-client-5.7 package.
Preparation for unpacking ... / 02-mysql-client-5.7_5.7.24-0ubuntu0.18.10.1_amd64.deb ...
Unpack Mysql-client-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Select the previously unselected mysql-server-core-5.7 package.
Preparation for unpacking ... / 03-mysql-server-core-5.7_5.7.24-0ubuntu0.18.10.1_amd64.deb ...
Unpack Mysql-server-core-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Select the previously unselected package libevent-core-2.1-6: amd64.
Preparation for unpacking ... / 04-libevent-core-2.1-6_2.1.8-stable-4build1_amd64.deb ...
Unpack Libevent-core-2.1-6: amd64 (2.1.8-stable-4build1) ...
Select the previously unselected mysql-server-5.7 package.
Preparation for unpacking ... / 05-mysql-server-5.7_5.7.24-0ubuntu0.18.10.1_amd64.deb ...
Unpack Mysql-server-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Select the previously unselected package libcgi-pm-perl.
Preparation for unpacking ... / 06-libcgi-pm-perl_4.40-1_all.deb ...
Unzip Libcgi-pm-perl (4.40-1) ...
Selection of the previously unselected package libfcgi-perl.
Preparation for unpacking ... / 07-libfcgi-perl_0.78-2build1_amd64.deb ...
Unzip libfcgi-perl (0.78-2build1) ...
Select the previously unselected libcgi-fast-perl package.
Preparation for unpacking ... / 08-libcgi-fast-perl_1% 3a2.13-1_all.deb ...
Libcgi-fast-perl (1: 2.13-1) unpack ...
Select the previously unselected package libhtml-template-perl.
Preparation for unpacking ... / 09-libhtml-template-perl_2.97-1_all.deb ...
Extract libhtml-template-perl (2.97-1) ...
Selection of the previously unselected mysql-server package.
Preparation for unpacking ... / 10-mysql-server_5.7.24-0ubuntu0.18.10.1_all.deb ...
Unpack Mysql-server (5.7.24-0ubuntu0.18.10.1) ...
Set up libevent-core-2.1-6: amd64 (2.1.8-stable-4build1) ...
Processing triggers for libc-bin (2.28-0ubuntu1) ...
Set up Libaio1: amd64 (0.3.111-1) ...
Processing trigger for systemd (239-7ubuntu10) ...
Set up libcgi-pm-perl (4.40-1) ...
Processing triggers for man-db (2.8.4-2) ...
Set up mysql-client-core-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Set up libfcgi-perl (0.78-2build1) ...
Set up libhtml-template-perl (2.97-1) ...
Set up Mysql-server-core-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Libcgi-fast-perl (1: 2.13-1) set up ...
Set up mysql-client-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Set up Mysql-server-5.7 (5.7.24-0ubuntu0.18.10.1) ...
Update Alternatives: Use /etc/mysql/mysql.cnf to provide /etc/mysql/my.cnf (my.cnf) in automatic mode
Renamed remote options for key_buffer and myisam-recover (if any)
Symlink creates /etc/systemd/system/multi-user.target.wants/mysql.service → /lib/systemd/system/mysql.service.
Job for mysql.service failed because the control process ended with error code.
For more information, see "systemctl status mysql.service" and "journalctl -xe".
invoke-rc.d: initscript mysql, action "start" failed.
● mysql.service - MySQL Community Server
Loaded: loaded (/lib/systemd/system/mysql.service; activated; manufacturer's default: activated)
Active: Enable (automatic restart) (result: exit code) since Sat 2019-01-05 17:08:57 UTC; 8ms ago
Process: 2726 ExecStartPre = / usr / share / mysql / mysql-systemd-start pre (code = stopped, status = 1 / FAILURE)

January 5, 17:08:57 Lubuntu Systemd[1]: mysql.service: Control Process Finished, Code = Status Completed = 1
January 5, 17:08:57 Lubuntu Systemd[1]: mysql.service: error with result & # 39; exit-code & # 39 ;.
January 5, 17:08:57 Lubuntu Systemd[1]: Error Starting MySQL Community Server.
dpkg: Error handling package mysql-server-5.7 (--configure):
Installed mysql server 5.7 package post-process script subprocess returned error exit status 1
dpkg: Dependency issues prevent configuring the MySQL server:
mysql-server depends on mysql-server-5.7; However:
The mysql-server-5.7 package is not yet configured.

dpkg: Error handling package mysql-server (--configure):
Dependency issues - remain unconfigured
Processing triggers for libc-bin (2.28-0ubuntu1) ...
No application report was written because the error message indicates a subsequent error from a previous error.
Processing trigger for systemd (239-7ubuntu10) ...
There were errors during processing:
MySQL Server 5.7
MySQL server
E: The subprocess / usr / bin / dpkg returned an error code (1).