magento2 – Magento 2 visibility “catalog” not saving in default store view

Magento 2 visibility “catalog” not saving in “default store view” but when store is “All store view” it is saving “catalog” but in default store view when visibility set “catalog” after save it is showing “catalog,search”

Using Magento 2.3.5p1

enter image description here
Anyone how to solve this?

dnd 5e – If you succeed on the saving throw for the Sickening Radiance spell, do you still take the level of exhaustion and emit the light?

The Sickening Radiance spell says:

When a creature moves into the spell’s area for the first time on a turn or starts its turn there, that creature must succeed on a Constitution saving throw or take 4d10 radiant damage, and it suffers one level of exhaustion and emits a dim, greenish light in a 5-foot radius.

The grammar and punctuation here makes me wonder: do the level of exhaustion and greenish light happen regardless of the result of the saving throw, just like how some spells still deal half damage when you succeed on the save?

I suspect they do. Otherwise it should have been written “…must succeed on a Constitution saving throw or take 4d10 radiant damage, suffer one level of exhaustion, and emit a dim, greenish light…”

permutation – How to solve this problem by the way of saving memory?

Eight different boys and five different girls are in a row. Girls are required to be next to each other. How many ways are there (the answer is $9!times5!$)?

Cases(Permutations(Array(boy, 8)~Join~Array(girl, 5)), {___, girl(_), 
   girl(_), ___}) // Length
General::nomem: The current computation was aborted because there was insufficient memory available to complete the computation.

However, the above code indicates that there is not enough memory. What is the memory saving way to solve this problem? Feel free to correct the grammar mistakes and unidiomatic expressions in my posts, please.

Users are saving over a fillable template and wrecking the original

We have a template that users need to modify and return as an attachment but they are modifying the original and saving it which then leaves their info for the next user. How do we stop this? They do need to complete the form (so it can’t be read only) – but not save back over the original.

Thanks in anticipation

samsung – ANT+ and UPSM (ultra power saving mode)

I have a Samsung device with ANT+ support and i would like to use in UPS mode.

In UPS mode with bluetooth enabled, the ANT+ is not working.
Why?
Any way to make it work?

In normal mode ANT+ works but Bluetooth has to be enabled.
Is there any dependency between these technologies?

ANT HAL service: 3.0.0

ANT Radio service: 4.16.00

ANT+ Plugins 3.6.40

(I can’t tag it as ‘ant+’)

How to deal with evince inserting substitution fonts in the fillable PDF when saving?

When I’m filling a given PDF file, the field font gets ugly after filling values (bigger and different font).

It seems to be related to the fact that evince performs fonts substitution at opening (menu > Properties…).

  • Times-Roman is substituted by Nimbus Roman No9 L
  • Helvetica is substituted by Nimbus Sans L
  • ZapfDingbats is substituted by Dingbats

Before filling the file, pdffonts doesn’t list those fonts:

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
Font-blah-blah-blah-blah-blah-01     Type 1C           Custom           yes yes no     170  0
Font-blah-blah-blah-blah-blah-02     Type 1C           Custom           yes yes no     171  0
Font-blah-blah-blah-blah-blah-03     Type 1C           Custom           yes yes no     172  0
Font-blah-blah-blah-blah-blah-04     Type 1C           Custom           yes yes yes    173  0
Font-blah-blah-blah-blah-blah-05     Type 1C           Custom           yes yes no     174  0
Font-blah-blah-blah-blah-blah-06     Type 1C           Custom           yes yes yes    175  0
Font-blah-blah-blah-blah-blah-07     Type 1C           Custom           yes yes no     176  0

After saving, the outputs change, those fonts are added as not embedded:

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
Font-blah-blah-blah-blah-blah-01     Type 1C           Custom           yes yes no     167  0
Font-blah-blah-blah-blah-blah-02     Type 1C           Custom           yes yes no     170  0
Font-blah-blah-blah-blah-blah-03     Type 1C           Custom           yes yes no     173  0
Font-blah-blah-blah-blah-blah-04     Type 1C           Custom           yes yes yes    176  0
Font-blah-blah-blah-blah-blah-05     Type 1C           Custom           yes yes no     179  0
Font-blah-blah-blah-blah-blah-06     Type 1C           Custom           yes yes yes    182  0
Times-Roman                          Type 1            Custom           no  no  no     118  0
Helvetica                            Type 1            Custom           no  no  no      45  0
ZapfDingbats                         Type 1            ZapfDingbats     no  no  no      46  0
Font-blah-blah-blah-blah-blah-07     Type 1C           Custom           yes yes no      31  0

The ugly rendering of the fields is here when I reopen the PDF. Is there a way to solve this problem, for example by restoring the original list font?

Second (related?) question: why pdffonts doesn’t notice about not embedded fonts in the first output?

sharepoint online – Version history not saving properties

I have 3 environments on which I have Versioning turned on. Each of them is created from the same PnP template, and has the same logicApps/etc connected to them. On one of them however, version history doesn’t seem to save data from custom columns. For example:

In working scenario, when I update columns X,Y,Z, – Where X and Y are custom columns, and Z is OBB one, 3 of them will appear under “properties” tab in version history of document set.

In wrong scenario, with the same update – only Z column will appear in properties of version history, built in one. custom ones are not present in there.

Any ideas what is it about?

8 – How to pass a field value from a parent node to its entity referenced children nodes when saving the parent node form

Drupal 8

Here is the scenario

I have a Company > Department > Employee… in that hierarchy.

Companies are already created previously.

On the Department node add form, there is an entity reference field to reference a Company. On that same Department node form, there is another Entity Reference field that leverages Inline Entity Form to add + reference Employee nodes on the fly. These Employee nodes also have a Company entity reference field.

The goal is to pass the Company field value from the Department node to the referenced Employee nodes when the Department form is saved.

I figure this may be accomplished with the Business rules module, and/or a hook form alter. Tried both without any traction. Any tips?