magento2 – how the window.config variable is updated after sending

I overwritten ConfigProviderInterface and got values ​​when loading the checkout page and it works really well, but the problem is this.

My variable window.configmsg depends on the shipping country. So if every customer changes the shipping country, we would like to change the message. in the order review block (comes from window.configmsg) according to country selection. It works fine when the page loads (when the country is selected), but doesn't work when the customer returns and the fourth when selecting the country.

PHP – Show warning if the Javascript page should be updated

I am doing a script that will get a notification when the page refreshes if you want to refresh

I have this code

window.onbeforeunload = function() {
  return 'estas seguro de refrescar la pagina';
};

The code does not always show the warning even if it is updated. He updates the page and restarts my progress bar. What I want to do before updating shows a warning whether you want to update or not

Powershell – SharePoint Online – Can the ID column value in a list be updated for an existing item?

Is there any way in SharePoint Online to update the ID column (for an existing item) in a list with our value?

We have a SharePoint list where I want to update the ID column value with my own value. I just want to update it for an article as it affects one of our solutions.

Free – Looking for TL job [Updated 27/04/20] | Forum promotion

I am currently looking for a job as a kind Group leader. I have a lot of time in my hands now that things have changed in my life for the better and I am looking for something that will fill my time.

Positions I'M GOING accept – – Community team leader, community team member, or review team leader.

Positions NOT ME want – GFX, coding, developer or one of the above jobs as a non-team leader.

I have a fair share of past experience, but I will find some more important ones:

Promotion Vault (Owner) – I built and ran this forum on XenForo.

Promotion Box (Owner) – I used to own and run this XenForo forum.

Forum promotion (Ex-Packager / Ex-Content-Team) – I was a Packager here and fulfilled the requests of the FP members. I helped run the FP blog and wrote articles.

State Of Sound (Community Team Leader) – I moderate the forum and enforce the guidelines and ensure that the forum remains active and friendly.

I am ideally looking for a place. I am not particularly fussy about forum software, but I will most likely reject your forum if it is on a free forum host or is still under development!

Please reply here with offers or PM me.

Thanks a lot!!

Updated – 04/27/20

8 – How can I transfer the result of updated views to drupalSettings?

I created a plugin for custom views.

I am trying to pass the results of the views in drupalSettings. I can access the data record with the template_preprocess as described below:

$variables('#attached')('drupalSettings')('test')('dataset') = $items;

However, the results are not updated with the "Views displayed" filter. However, when I set a drupalSettings based on the views, the results count. It is being updated. So I tried to turn off viewing caching, but still no luck.

Here is my current code:

function template_preprocess_test(&$variables) {
  $items = &$variables('test')('items');

  $variables('content')('list') = (
    '#theme' => 'test_dataset_list',
    '#items' => $items
  );

  $variables('#attached')('drupalSettings')('test')('dataset') = $items;
}

To set the dataset in custom view style:

function template_preprocess_test_views_style(array &$variables) {
  // Only run the preprocessor if it is a view.
  if (empty($variables('view'))) {
    return;
  }

  $view = $variables('view');
  $style = $view->style_plugin;
  $options = $style->options;
  $items = ();

  foreach ($variables('rows') as $k => $row) {
    // @todo should use render arrays instead of actual output
    $item('dataset') = ();
    $item('dataset')('custom1') = (isset($row('#custom1')) && !empty($row('#custom1'))) ? $row('#custom1') : NULL;;
    $item('dataset')('row') = $row;
    $items() = $item;
  }

  $content = (
    '#theme' => 'test',
    '#test' => (
      'items' => $items
    ),
  );

  $variables('content') = $content;
}

Update – Is there a way to inform the composer about manually updated modules?

I am working on a Drupal 8 site and tend to update some modules:

  1. I run it composer outdated 'drupal/*' Command and it shows me the list of modules that need to be updated.
  2. To run composer update drupal/module_name --with-dependencies In the end, the expenses are discarded.
  3. Therefore I decided to update the module via the administration interface. After updating the database changes, the status report no longer shows an update, but is executed outdated Command in the composer lists the modules again.

This means that I have to somehow tell the composer about this manual update (I think by changing composer.json and / or composer.lock, but I haven't found the process yet.

spfx – Update the client-side web application in the Sharepoint Online App Library – Not updated

I deployed an app on Sharepoint with 3 client-side web parts.
When I add it for the first time, its version = 1.0.0.0.

When I make changes to the solution:
Change the version to 2.0.0.0
gulp bundle --ship
gulp package-solution --ship

Then upload the .sppk file to the Apps for Sharepoint screen. I am overwriting the old file. It is activated, provided and error-free.

  • I'm checking in the changes (I tried not to check in too)

But then I go into the content of the site and the app still shows v1.0.0.0.

The only way to update this is:

  1. Go to the "Classic Experience"
  2. Remove the app
  3. Delete from the trash
  4. Add the app again on the "Add app" page.
  5. Sometimes I have to do it a couple of times for it to work.

Am I doing something wrong Is the app cached by Sharepoint or something?

In the event of downtime before the updated app has been successfully added, nothing is displayed on all pages on which these web parts are available.

Any help would be appreciated. Thanks a lot!!

magento2 – Magento 2 shipping costs are only updated when the address is changed if a standard method is activated

Magento 2.3 EE Custom shipping module

I developed a custom shipping method to connect directly to an ERP system that contains all prices for the customer's shopping cart and shipping address.

This works very well with the collectRates concept in the carrier service.

Since the tariffs come directly from an ERP, only this one method has to be activated on the site.

Unfortunately, the standard behavior when updating the rates at the checkout does not occur when the address fields are changed. I also don't see any errors in the console or an attempt to update prices.

As part of debugging, I took out my custom shipping module and activated an integrated method (free delivery). The update of prices in the event of address changes came back. I re-activate my module and the update of the rates on change is returned. πŸ™‚ πŸ™‚

At the moment, a & # 39; standard & # 39; method must be activated in order for me to have the expected standard behavior. For my purpose, I have activated the standard free shipping method with a very high minimum amount, and although the value of the shopping cart does not reach the minimum spending threshold, the behavior when updating changes remains.

I don't want to activate any of the built-in methods and am looking for a solution to force rates to change when the address changes.

Amazon Web Services – AWS Config resource inventory is not updated

I created a service link role configuration and activated the configuration recorder. Then a rule managed by AWS was created – "s3-bucket-server-side-encryption-enabled".

There are 5 buckets in the region, some of which have bucket guidelines attached, but there is no explicit denial. 4 of them are encrypted and one is not – I created it to test the rule. Whenever I run the rule, it only recognizes 2 out of 5 buckets and says that the rule is compliant while it is not. When I check the resource inventory under S3 buckets, only two are shown. However, the configuration history shows that it was successfully delivered today.

I've waited a few days to see if it updates, but it's not. In Cloudtrail, I can only see two events called "PutEvaluations"What checks the two buckets. What could be the reason? And how can I fix errors?