terminal – PuTTY | Gtk-WARNING **: : cannot open display:

I’m running macOS Big Sur v11.5.2. I’ve looked for solutions, but couldn’t find anything on macOS.

I’m getting this warning when attempting to install PuTTY:

user@name-iMac ~ % cp /opt/local/bin/putty ~/Desktop/PuTTY
user@name-iMac ~ % Putty
(Putty:11111): Gtk-WARNING **: 11:11:11.111: cannot open display:
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
(Process completed)

Terminal window showing PuTTY error

I’ve installed MacPorts, Homebrew, Command Line Tools for Xcode, and Xcode (accepted the license agreement), and have had no problems up until this point. Am I missing a step?

I know there are much better alternatives to PuTTY, but it is required for my course.