tp link – Installing jeremyb31/rtl8812au-1 gives “Error! Module version”


88XXau:
Running module version sanity check.
Error! Module version v5.3.4_28226.20180614_---- for 88XXau.ko
is not newer than what is already found in kernel 4.15.0-121-generic (v5.6.4.2_35491.20191025).
You may override by specifying --force.

Following the usual :

sudo apt install git dkms
git clone https://github.com/jeremyb31/rtl8812au-1.git
cd rtl8812au-1
sudo ./dkms-install.sh```

The tplink wifi adaptor just doesn't get recognized...