tunnel – Pfsense GRE to Proxmox Openvirtualswitch gateway not going up

So, I run pfsense on Hetzner Cloud and proxmox on Hetzner Cloud. Both are VMs. The Hetzner network is very restricted. I found a solution: GRE tunnels.

The following setup works:

pve machine = 10.0.0.3, test machine = 10.0.0.4

pve machine /etc/network/interfaces:

auto vmbr0

iface vmbr0 inet manual

ovs_type OVSBridge

post-up ovs-vsctl add-port vmbr0 tep0 -- set interface tep0 type=internal

post-up ifconfig tep0 192.168.1.1 netmask 255.255.255.0

post-up ovs-vsctl add-port vmbr0 gre0 -- set interface gre0 type=gre options:remote_ip=10.0.0.4

test machine /etc/network/interfaces:

auto vmbr0

iface vmbr0 inet manual

ovs_type OVSBridge

post-up ovs-vsctl add-port vmbr0 tep0 -- set interface tep0 type=internal

post-up ifconfig tep0 192.168.1.2 netmask 255.255.255.0

post-up ovs-vsctl add-port vmbr0 gre0 -- set interface gre0 type=gre options:remote_ip=10.0.0.3

After restarting machines, I can ping both of them and I can create a LXC container on the proxmox with ip 192.168.1.5, I can ping that one from both machines. Now I removed the test machine and went with pfsense.

pve machine (still 10.0.0.3) pfsense = 10.0.0.2

pve machine /etc/network/interfaces:

auto vmbr0

iface vmbr0 inet manual

ovs_type OVSBridge

post-up ovs-vsctl add-port vmbr0 tep0 -- set interface tep0 type=internal

post-up ifconfig tep0 192.168.1.1 netmask 255.255.255.0

post-up ovs-vsctl add-port vmbr0 gre0 -- set interface gre0 type=gre options:remote_ip=10.0.0.2

pfsense setup:

GRE configuration

Interface screen

But, even after restarting both machines. the gateway won’t go up:

Gateways

I have no clue anymore. It works on a test machine, but I’m missing something on pfsense? Has anyone any idea?