upgrade – What happened to pyqt5 when upgrading to 29.04.1


After I upgraded to Ubuntu 20.04.1 my HP Officejet 3830 stopped working. I downloaded hplip-3.20.9.run from the HP site. When I try to install, all is well until the program tries to get pyqt5. After 3 tries it reports error code 100 and refuses to continue. Is there a way, step by step instructions needed, to install the required dependencies? Or am I going to need a new printer/scanner?