upgrading – Update Drush in Docker4drupal

Assuming you’re using the default wodby/drupal:8-7.1-3.3.2 container image, the drush launcher is already installed in the PHP FPM container.

Thus, your next step is to update your Drupal 8 composer drush dependency via composer:

composer require 'drush/drush:^9'

When drush launcher executes under your web root it will pick up the version 9 that’s installed in your vendor dir.