visualg – O algoritmo roda, mas não mostra o numeros entre 0 e 100, 101 a 200 e numeros maiores que 200


algoritmo "questao 1"
var
n, i, j, k, num: inteiro

inicio
   n <- 0
   enquanto n <= 1 faca
   n <- n + 1
   escreva("Digite um numero: ")
   leia(num)
se (n >= 0) e (n <= 100) entao
   senao
      se(n >= 101) e ( n <= 200) entao
        senao
           se( n >= 200) entao
              fimse
              fimse
              fimse
              fimenquanto
              escreval("numeros entre 0 e 100: ", i)
              escreval("numeros entre 101 e 200: ", j)
              escreval("numeros maiores que 200: ", k)
fimalgoritmo