windows – Can’t get access to Hyper-V servers

I have 3 Hyper-V servers at work.

After reconfiguring the network, the servers became unavailable.
iLo works (vlan 123), but I cannot ping the physical ports.
The server only pings itself.
The ports are configured as trunk on the switch.
Arp table is completely empty.

HPE ProLiant DL60 Gen9 Server

I did a full reset on one of the servers.
I reinstalled HV2019 according to the following instructions:
http://woshub.com/install-configure-free-hyper-v-server/

Made the following settings in BIOS:
https://techlibrary.hpe.com/docs/iss/proliant_uefi/UEFI_TM_030617/s_config_vlan_config.html

I am guessing there is a traffic tagging issue.

I tried to configure VlanIDs on the ports, but nothing worked for me:

VlanID configuration

Here is the “show run” of the switch (Gig1/0/18 – 20 connected to servers):

Building configuration...

Current configuration : 5406 bytes
!
! Last configuration change at 22:53:50 MSK Fri Jan 29 2021 by niko
! NVRAM config last updated at 22:42:04 MSK Fri Jan 29 2021 by niko
!
version 15.2
no service pad
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
!
hostname sw-4219-1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Hc3F$IPcHvctsk6UGOorKwOG5s1
!
username jujin secret 5 $1$LlWA$MQt/ZwomMlhF6TQ4MvhcO1
username niko privilege 15 secret 5 $1$j9if$3hkvCYGo/CU6kqxC/NNQI0
no aaa new-model
clock timezone MSK 3 0
switch 1 provision ws-c2960x-24ts-l
ip arp inspection validate src-mac dst-mac ip
!
!
ip dhcp snooping database flash:/snoopdatabase
ip dhcp snooping database write-delay 60
ip dhcp snooping database timeout 0
ip domain-name tcs.miet.ru
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree portfast default
spanning-tree portfast bpduguard default
spanning-tree portfast bpdufilter default
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,200,423,898,1000
 switchport mode trunk
 ip arp inspection trust
 ip dhcp snooping trust
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 switchport access vlan 898
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/2
 switchport access vlan 898
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 switchport access vlan 898
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/4
 switchport access vlan 898
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/5
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/6
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/7
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/8
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/9
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/10
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/11
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/12
 switchport access vlan 423
 switchport mode access
 switchport voice vlan 1000
 spanning-tree portfast
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
 description to HV-SERVERS
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,423,898
 switchport mode trunk
 ip arp inspection trust
!
interface GigabitEthernet1/0/19
 description to HV-SERVERS
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,423,898
 switchport mode trunk
 ip arp inspection trust
!
interface GigabitEthernet1/0/20
 description to HV-SERVERS
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,423,898
 switchport mode trunk
 ip arp inspection trust
!
interface GigabitEthernet1/0/21
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,200,423,898,1000
 switchport mode trunk
!
interface GigabitEthernet1/0/22
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,200,423,898,1000
 switchport mode trunk
!
interface GigabitEthernet1/0/23
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,200,423,898,1000
 switchport mode trunk
 ip arp inspection trust
 channel-protocol pagp
 channel-group 1 mode desirable
 ip dhcp snooping trust
!
interface GigabitEthernet1/0/24
 switchport trunk native vlan 777
 switchport trunk allowed vlan 123,200,423,898,1000
 switchport mode trunk
 ip arp inspection trust
 channel-protocol pagp
 channel-group 1 mode desirable
 ip dhcp snooping trust
!
interface GigabitEthernet1/0/25
 switchport mode trunk
 shutdown
!
interface GigabitEthernet1/0/26
 shutdown
!
interface GigabitEthernet1/0/27
 shutdown
!
interface GigabitEthernet1/0/28
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan200
 ip address 172.17.9.37 255.255.255.224
!
ip default-gateway 172.17.9.33
no ip http server
no ip http secure-server
!
ip ssh version 2
!
!
!
banner login ^C

UNAUTHORIZED ACCESS TO THIS DEVICE IS PROHIBITED
You must have explicit, authorized permission to access or configure this device.
Unauthorized attempts and actions to access or use this system may result in civil and/or
criminal penalties.
All activities performed on this device are logged and monitored.

^C
!
line con 0
 logging synchronous
 login local
line vty 0 4
 logging synchronous
 login local
 transport input ssh
line vty 5 15
 logging synchronous
 login local
 transport input ssh
!
ntp server 82.179.190.57
end

Here are the interface settings:

NIC 1
NIC 2

Ping:

Ping from server

Do you have any idea?
I’ll be very thankful.