windows subsystem for linux – Running sudo snap on WSL2 with ubuntu18.04

By following WSL: Am I running version 1 or version 2? I’ve verified that my WSL is version 2. Running uname -a outputs “Linux DESKTOP 4.4.0-18362-Microsoft”

I want to install microk8s on WSL2 so that I can use kubeflow. There seems to be many instructions on how to install microk8s by enabling sudo snap command by enabling sytemD however none of the instruction seem to work on mine.

1. following -> https://gist.github.com/djfdyuruiry/6720faa3f9fc59bfdf6284ee1f41f950

I got stuck on /tmp/install-sg.sh && rm /tmp/install-sg.sh running it outputs Error: Too many request

2. follwing -> https://wsl.dev/wsl2-microk8s/

I can’t even run WSL command, when I do it outputs:

WSL
Wsman Shell commandLine, version 0.2.1

USAGE: wsl COMMAND (PARAMS...)

COMMANDS:
identify  - WS-Identify
enum      - WS-Enumerate
get       - WS-Get
put       - WS-Put
invoke    - WS-Invoke
xclean    - Delete all files generated by this tool set
xcred     - Create or display credential file
xcert     - Get server certificate (saved to <IPADDRESS>.crt)

PARAMS specification is specific to a COMMAND.

Output will be saved to ./response.xml. If you want to run parallel
executions in the same directory, define RTFILEPREFIX in the environment.
Doing so may significantly increase files generated.

Requires: curl, xmllint, GNU core utilities.
Optional: xsltproc for output formatting, gpg for encrypted credential.
Optional: wget as alternate for curl when not available.

and when I try to run apt install -yqq fontconfig daemonize it outputs:

E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

Thanks in advance!