wireless – Headset microphone connected, but not producing sound


I have a wireless headset that I want to use both for sound and as microphone. However, when connecting it to the computer and selecting “Headset Head Unit (HSP/HFP)” in stead of “High Fidelity Playback (A2DP Sink)”, the computer does see the headset microphone, but no sound is registered. The headset does work as supposed to when connected to my phone, so it should not be a hardware problem in the headset microphone itself.

I have looked at the settings in alsamixer, but those don’t make sense to me. Additionally, all settings in pavucontrol and the system audio settings seem to be in the right place.

The microphone of my laptop is of such bad quality (very tinny sound with insane background noise), that I am now almost resolved to use my phone for video meetings. I would love to get the headset working properly.

The output from arecord -l is as follows:

**** List of CAPTURE Hardware Devices ****
card 1: PCH (HDA Intel PCH), device 0: ALC282 Analog (ALC282 Analog)
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Amixer:

Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback (on)
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback (on)
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback (on)
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback (on)
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback (on)

aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI (HDA Intel HDMI), device 3: HDMI 0 (HDMI 0)
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI (HDA Intel HDMI), device 7: HDMI 1 (HDMI 1)
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI (HDA Intel HDMI), device 8: HDMI 2 (HDMI 2)
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI (HDA Intel HDMI), device 9: HDMI 3 (HDMI 3)
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI (HDA Intel HDMI), device 10: HDMI 4 (HDMI 4)
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH (HDA Intel PCH), device 0: ALC282 Analog (ALC282 Analog)
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH (HDA Intel PCH), device 1: ALC282 Digital (ALC282 Digital)
  Subdevices: 1/1
  Subdevice #0: subdevice #0